Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have this problem where I can't download packages in my android sdk and eclipse. Apparently these programs can't fetch the repository. For android sdk, it always gets stuck on fetching the addon_list.xml file. It then becomes unresponsive. Eclipse just can't get the list regardless of how long I waited.

This is the same problem I'm having: http://stackoverflow.com/questions/9035773/eclipse-android-sdk-wont-fetch-update-connect-or-do-anything-useful

I've done most of the solutions I found online but none of them works.

I've isolated the problem though. I dual boot windows, but my windows can get the files from the android repository. So I thought it's ubuntu, but I've tried running android sdk at school while using ubuntu and I was able to get the repository files fine. That also eliminated my wireless driver and the sdk as the source of the problem.

The router is what I think the source of the problem. Is there some sort of setting that needs to be enabled or disabled for this to work properly? I've been experimenting but none really worked yet and I'm afraid to touch other settings. I was thinking that there must be something wrong with how my router interacts with the OS.

So what should I do? Really need this to work for a project.

I'm using DSL g640t router.

share|improve this question
    
Is there an error message that comes up when you attempt anything? –  hexafraction Sep 25 '12 at 7:02
    
Notable errors that I read were: java.NoRouteToException then followed by some stuff and "network unreachable". android SDK becomes unresponsive so I can't do anything. The files that I need are very big, so I can't download at uni. I know i can attempt an offline install, but this problem will still persist and so I won't get probable necessary updates or new versions. –  thatguywhowas Sep 25 '12 at 8:20
    
It's probably your download speed stalling out on some larger files. If it "works on windows" apparently linux networking or the java network layer abandons the connection after a shorter time period. I can tell you on solid network connections they all "usually" work (some exceptions in some of the older API blobs) and on slower connections they work less often (A person from Brazil I was talking to had trouble with over half of the connections timing out). If you can't fix it inside eclipse you HAVE to download outside to get it to work. –  hbdgaf Sep 25 '12 at 12:02
    
I'm not sure about that since my download speed is pretty decent, I've downloaded software in ubuntu pretty quick. I wouldn't know about the larger files since sdk gets stuck on the first file that's supposed to be fetched and that's only an xml file and only some kb big. –  thatguywhowas Sep 25 '12 at 14:47

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.