Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Hello I'm running a web application on port 8000. When I access it from the host server localhost:8000 it responds ok, also works, but does not work. is the ip of my server.

Also if i try to go to another web application running on port 80 it works

I enabled ufw firewall and set ufw default allow. I am using ubuntu server 12.04

Any suggestions on why I can't get to my app on port 8000 using the ip-address:8000?

Thanks in advance!

share|improve this question
The application is probably listening to the localhost address ( rather than to all local addresses ( You haven't provided enough information on your app for people to help you fix this though. – James Henstridge Sep 25 '12 at 2:28
My app running on port 8000 is just a website. Perhaps this netstat copy/paste will reveal more about my network: – Marionette Sep 25 '12 at 2:34
Well, running netstat -tln | grep 8000 might cast some light on the problem. If the server's local address is rather than, then it will only be reachable via the loopback interface. – James Henstridge Sep 25 '12 at 6:56
check your iptables – user61928 Sep 26 '12 at 8:31

As @JamesHenstridge points out, the behaviour you're observing is not due to Ubuntu blocking your application on some IPs, but due to your application explicitly binding only to the local loopback interface (127.x.x.x). At least if you didn't install and set up a firewall to specifically block that port.

You need to consult your application's documentation to see if there's a setting to make it listen on other (or on all) interfaces.

share|improve this answer
Also are you familiar with port forwarding on your router? If you are going to connect to it from the internet on port 8000 you need to forward port 8000 to that machines ip. – wlraider70 Mar 21 '13 at 1:35

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.