Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am having a problem that doesn't seem to be common based on searching various forums.

I cannot run the Make command.


The program 'make' is currently not installed. You can install it by typing:
sudo apt-get install make

So do this:

sudo apt-get install make
Reading package lists... Done
Building dependency tree       
Reading state information... Done
make is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 4 not upgraded.

But then when I try to run Make I get the same message. What's up?

Edit: Ubuntu 12.04 64bit Desktop fresh install.

share|improve this question
Probably make is not in the correct $PATH Try sudo apt-get remove make sudo apt-get install make – Tachyons Sep 25 '12 at 0:46
IT WORKED! You are awesome. – snoopdogg Sep 25 '12 at 0:50
:), I am gonna post it is an answer, please press tick mark on it – Tachyons Sep 25 '12 at 1:23
@snoopdogg you should accept the answer – chwi Mar 8 '13 at 19:01

Probably it is due command make is not present in system PATH, so remove and reinstall it.

sudo apt-get remove make
sudo apt-get install make

or with

sudo apt-get install --reinstall make
share|improve this answer

Run this command to install make and all the packages needed to build your code.

sudo apt-get install build-essential
share|improve this answer
This worked for me... – cyberboy Apr 17 at 21:59

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.