Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I thought that I had set syndaemon to disable the touchpad while I type, and for 0.8 seconds afterwards. In order to change the default touchpad delay of 2.0 seconds, which is hard-coded into the touchpad settings dialog, I unchecked "Disable touchpad while typing" and added "syndaemon -i 0.8 -K -R -t" to the list of startup applications. Most of the time now, the touchpad doesn't register taps while I type, as I want. However, sometimes while typing, the cursor still flicks to a random spot in the text box, even while I am in the middle of typing. I don't take anywhere near 0.8 seconds between keystrokes - what could be happening here?

To verify that syndaemon is running with the correct options when the unwanted behavior occurs, I run:

$ ps -ef | grep syndaemon
user      1840  1747  0 Sep23 ?        00:00:00 syndaemon -i 0.8 -K -R -t

Everything seems fine. What could the problem be? How do I go about finding out if syndaemon is to blame?

share|improve this question
Did you ever find a solution for this? I'm experiencing the same problem. – Computarch Dec 20 '13 at 3:34
I never found a solution. It looks to me like a bug. I haven't updated to the newest version of Ubuntu yet, so it might have been fixed some time after 12.04. – Thucydides411 Jan 15 '14 at 19:26

-t Only disable tapping and scrolling, not mouse movements, in response to keyboard activity.

See man syndaemon for more info.

Basically, you've disabled tapping and scrolling, but not movement with that command. Try something like this instead:

syndaemon -i 0.8 -K -R
share|improve this answer
I don't mind the movement of the pointer, which is why I use -t, but the moving of the keyboard input cursor (by tapping) is the problem. – Thucydides411 Sep 24 '12 at 20:52
What's "keyboard input cursor", and how many cursors are there? – mikewhatever Sep 24 '12 at 21:05
The cursor is the thing in the textbox that shows you where the characters will appear if you type. The pointer is the thing that you move with your mouse. I said "keyboard input cursor" the second time to try to get that across. – Thucydides411 Sep 24 '12 at 22:46
I see. Did you get the same behavior when the timeout was 2 seconds? – mikewhatever Sep 24 '12 at 23:15
Adjusting the timeout doesn't help. The timeout doesn't always hold. Often, while I am in the middle of typing a word, the cursor will jump to another point. The time between keystrokes in that case is on the order of 100-200ms, far shorter than any timeout I've ever set. For example, I was just typing '**kwargs' in a python script. The first '*' appeared in the correct position, but the second '*', typed almost immediately afterwards (I double-tapped the key quickly), appeared at a different location, as the cursor had switched positions in between keystrokes. – Thucydides411 Nov 2 '12 at 19:21

The only way I've found to make syndaemon work in its current incarnation is to disable the XRecord support (it doesn't seem to work at all), and use -m 50 (that is, poll every 50 milliseconds).

So: syndaemon -m 50

However, this seems to make the keyboard lose keypresses and flip to "shift always down" modes and such instead, so essentially syndaemon seems to be useless. The only way to use a touchpad is to manually disable the touchpad with a keyboard shortcut.

share|improve this answer
The -m 50 solved my weird "Won't wake up again" problem. Cheers! – JayKuri Apr 2 at 21:51

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.