Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I had a system running 12.04 with a Radeon HD4870, and had the monitors correctly setup. I installed a second video card (Radeo HD5700), and can't get the default Monitor app to detect the monitor.

The HD4870 has two displays connected via DVI, and the HD5700 has one display connected via DVI - VGA adapter.

It appears that both cards are detected via lspci | grep VGA:

06:00.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI RV770 [Radeon HD 4870]
07:00.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI Juniper [Radeon HD 5700 Series]

But I can't seem to get anything to show up on the new monitor. I tried looking into xorg.conf, but it didn't have anything in there that would have given me any hints.

Xorg.conf:

Section "Screen"
    Identifier  "Default Screen"
    DefaultDepth    24
EndSection

Section "Module"
    Load    "glx"
EndSection

Any suggestions on how to proceed?

Note: I also tried to install the ATI-proprietary drivers, and it wouldn't allow the setup I wanted due to Xinerama not allowing large enough desktop areas.

share|improve this question

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.