Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have been strugling with trying to get my sound card working under Linux, from the command line it reports back as follows:

user@desktop:~$ sudo lspci -v | grep -A7 -i "audio"
84:04.0 Multimedia audio controller: C-Media Electronics Inc CMI8788 [Oxygen HD Audio]
    Subsystem: ASUSTeK Computer Inc. Device 8521
    Flags: bus master, medium devsel, latency 64, IRQ 11
    I/O ports at f000 [size=256]
    Capabilities: [c0] Power Management version 2

user@desktop:~$ lshw -C sound
WARNING: you should run this program as super-user.
  *-multimedia UNCLAIMED  
       description: Multimedia audio controller
       product: CMI8788 [Oxygen HD Audio]
       vendor: C-Media Electronics Inc
       physical id: 4
       bus info: pci@0000:84:04.0
       version: 00
       width: 32 bits
       clock: 33MHz
       capabilities: bus_master cap_list
       configuration: latency=64 maxlatency=24 mingnt=2
       resources: ioport:f000(size=256)
       description: Audio device
       product: Barts HDMI Audio [Radeon HD 6800 Series]
       vendor: Hynix Semiconductor (Hyundai Electronics)
       physical id: 0.1
       bus info: pci@0000:85:00.1
       version: 00
       width: 64 bits
       clock: 33MHz
       capabilities: bus_master cap_list
       configuration: driver=snd_hda_intel latency=0
       resources: irq:384 memory:fbe40000-fbe43fff

Checking around a bit I find that while the system seems to recognize it, alsa does not seem to be recognizing it as an audio device. I've already tried to recompile the relevent modules and I'm still not having much luck. Also, it appears that based upon the version and kernel it should have been good to go out of the box so why it is not working is a bit of a mystery.

user@desktop:~$ cat /etc/issue
Ubuntu 12.04.1 LTS \n \l

user@desktops:~$ cat /etc/lsb-release 
user@desktop:~$ uname -r
user@desktop:/proc/asound$ cat version 
Advanced Linux Sound Architecture Driver Version 1.0.24.

The snd-oxygen module appears to be loading correclty and sudo modinfo snd-oxygen reports the following:

user@desktop:~$ sudo modinfo snd-oxygen
filename:       /lib/modules/3.2.0-31-generic/kernel/sound/pci/oxygen/snd-oxygen.ko
license:        GPL v2
description:    C-Media CMI8788 driver
author:         Clemens Ladisch <>
srcversion:     396D66C73AFE20AFAF981B5
alias:          pci:v000013F6d00008788sv00007284sd00009781bc*sc*i*
alias:          pci:v000013F6d00008788sv00007284sd00009761bc*sc*i*
alias:          pci:v000013F6d00008788sv00005431sd0000017Abc*sc*i*
alias:          pci:v000013F6d00008788sv0000415Asd00005431bc*sc*i*
alias:          pci:v000013F6d00008788sv000014C3sd00001711bc*sc*i*
alias:          pci:v000013F6d00008788sv000014C3sd00001710bc*sc*i*
alias:          pci:v000013F6d00008788sv000013F6sd0000FFFFbc*sc*i*
alias:          pci:v000013F6d00008788sv000013F6sd00008782bc*sc*i*
alias:          pci:v000013F6d00008788sv00001043sd00008467bc*sc*i*
alias:          pci:v000013F6d00008788sv00001A58sd00000910bc*sc*i*
alias:          pci:v000013F6d00008788sv0000147Asd0000A017bc*sc*i*
alias:          pci:v000013F6d00008788sv000013F6sd00008788bc*sc*i*
alias:          pci:v000013F6d00008788sv000013F6sd00000010bc*sc*i*
alias:          pci:v000013F6d00008788sv000013F6sd00000001bc*sc*i*
alias:          pci:v000013F6d00008788sv000010B0sd00000219bc*sc*i*
alias:          pci:v000013F6d00008788sv000010B0sd00000218bc*sc*i*
alias:          pci:v000013F6d00008788sv000010B0sd00000217bc*sc*i*
alias:          pci:v000013F6d00008788sv000010B0sd00000216bc*sc*i*
depends:        snd-oxygen-lib,snd
intree:         Y
vermagic:       3.2.0-31-generic SMP mod_unload modversions 
parm:           index:card index (array of int)
parm:           id:ID string (array of charp)
parm:           enable:enable card (array of bool)
share|improve this question
up vote 1 down vote accepted

Check out; it appears your kernel is too old.

For the Xonar DGX, you need either kernel 3.5 or some recent snapshot of the alsa-driver package.

share|improve this answer
Thanks for the comment; however, that's been checked and I've updated the question with the additional information. The kenernl version is 3.2.0 and the alsa version is 1.0.24 so according to the matrix it should have just worked. – rjzii Sep 25 '12 at 11:10
Is the snd-oxygen module loaded? Is there any error message in the system log when you try to load it? – CL. Sep 25 '12 at 11:27
From the looks of lsmod | grep snd_oxygen it looks like it is loaded along with snd_oxygen_lib. I didn't see anything obvious when grepping /var/log/ but which log should get a close examination? – rjzii Sep 25 '12 at 11:52
Run rmmod snd-oxygen and modprobe snd-oxygen; then look into /var/log/messages or at the output of dmesg. – CL. Sep 25 '12 at 11:54
I'm not seeing anything unusual in those logs and the device is still reporting that it is UNCLAIMED. – rjzii Sep 25 '12 at 12:01

Someone suggested typing alsamixer in console, then pressing F6, choosing Xonar as soundcard and then there are switches like "Analog output" which you can change from "Front panel" to the ones in the back, for example. This helped me.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.