Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I run 12.04 on a ASUS laptop that's about 3+ years old, that has a bad battery. (Requires constant AC power.)

I recently did an update that included a kernel. I ran the update and rebooted, and for some reason , grub couldn't find the kernel, and I was stuck there for awhile. Being a relatively inexperienced Linux user, I decided to load my live USB, copy over files I wanted to keep, and reinstall. Mid-copy , I bumped my power cable and unplugged the computer. When I booted back up, it loaded my hard disk install without problem.

Why did this happen in the first place, what fixed it, and how can I avoid this problem in the future?

share|improve this question

2 Answers 2

It seems that the install hadn't completed properly for some reason: specifically it had not updated the grub configuration to change the boot options.

This does not explain what fixed the problem, but it seem likely that a subsequent update finished the process. You could have run update grub to get it to update the list of kernels:

sudo update-grub
share|improve this answer

You can check your kernel list.

Open terminal Ctrl + Alt + T and type this command :

dpkg --list | grep linux-image 

Now check your current kernel:

uname -r 

Update your grub to make your newest kernel on the list.

sudo update-grub
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.