Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm new to Linux, and I've just installed Ubuntu on my Dell inspiron 15R Special Edition.

The ATI Radeon HD 7730M is running by default, instead of the on-board intel HD Graphics 4000. I searched as much as possible on the internet and found no solution so far. I believe someone would help me here.

share|improve this question

6 Answers 6

up vote 4 down vote accepted

The ATI driver available at Ubuntu Additional Drivers don't install correctly. To fix this issue, install the latest stable version from the ATI suporte site and you'll get the AMD Catalyst Control Center, a GUI with an option to Switchable Graphics.

To install it, follow the instructions below.

enter image description here

1) First, check the software sources, then paste this command into the terminal to install the dependencies:

sudo apt-get install build-essential cdbs dh-make dkms execstack dh-modaliases fakeroot

1-A) ONLY IF you have a 64 bit system, do this EXTRA step:

sudo apt-get install ia32-libs-multiarch:i386 lib32gcc1 libc6-i386 ; cd /usr ; sudo ln -svT lib /usr/lib64

2) Paste these commands into the terminal to create a new folder and download the latest catalyst driver:

 mkdir ~/amd-catalyst-driver; cd ~/amd-catalyst-driver/
 wget -c wget -c http://www2.ati.com/drivers/linux/amd-driver-installer-catalyst-12.10-x86.x86_64.zip
 unzip amd-driver-installer-catalyst-12.10-x86.x86_64.zip

3-A) IF you have Intel HD graphics AND discrete ATI GPU, then do this, click NEXT > NEXT > etc (and reboot):

 sudo sh amd-driver-installer-catalyst-12.10-x86.x86_64.run

3-B) ONLY IF you have just the ATI Graphics card, then try to do this instead, but it could take a while:

 sudo sh amd-driver-installer-catalyst-12.10-x86.x86_64.run --buildpkg Ubuntu/precise
 sudo dpkg -i fglrx*.deb

4-A) Overwrite the /etc/X11/xorg.conf file(anyway):

 sudo amdconfig --initial -f

4-B) Force the use of the new xorg.conf file:

 sudo amdconfig --input=/etc/X11/xorg.conf --tls=1

6) Reboot the computer and you're done:

 sudo reboot

7) To verify your installation, in terminal type:

 fglrxinfo ; fgl_glxgears

8) To switch between the GPUs, run one of the following commands and re-start X to take effect

8-A) Activate discrete GPU (High-Performance mode), must re-start X to take effect

 sudo aticonfig --px-dgpu
 fglrxinfo ; fgl_glxgears

8-B) Activate integrated GPU (Power-Saving mode), must re-start X to take effect

 sudo aticonfig --px-igpu
 fglrxinfo ; fgl_glxgears

SOURCES:

http://blog.wapnet.nl/2012/07/ubuntu-12-04-install-ati-videodrivers/ http://wiki.cchtml.com/index.php/Hardware http://support.amd.com/br/gpudownload/linux/Pages/radeon_linux.aspx http://forums.linuxmint.com/viewtopic.php?f=191&t=112234 http://ubuntuforums.org/showthread.php?t=1930450

share|improve this answer
    
What do you mean by "Check the sources" ? –  Muhammad Gelbana Nov 15 '13 at 23:09

I have Ubuntu 13.10 on Dell Inspiron 7520 SE (Intel and AMD Radeon H 7730m graphic cards) I followed this solution and it enabled my ATI card, frankly I'm not sure if it will switch automatically !

Basically, after installing Ubuntu, run this command

sudo apt-get install fglrx fglrx-pxpress
share|improve this answer

I've tried your tutorial, everything goes ok. Then when I reboot the machine I get terminal login (tty).

To solve it, I have to rename the xorg.conf.original-0 to xorg.conf so my notebook can enter on Kubuntu again.

Any ideas what it's wrong? Thanks!

$ fglrxinfo
X Error of failed request:  BadRequest (invalid request code or no such operation)
  Major opcode of failed request:  135 (GLX)
  Minor opcode of failed request:  19 (X_GLXQueryServerString)
  Serial number of failed request:  12
  Current serial number in output stream:  12
share|improve this answer

I have the same computer. Unless I'm totally blind, the BIOS does not have a mux switch. As far as I can tell the best way to switch off the card is to use vgaswitcheroo:

# echo "OFF" > /sys/kernel/debug/vgaswitcheroo/switch

If you don't ever use the card (like me), you could run this command in a startup script.

share|improve this answer
    
I should add that udev seems to autodetect these cards in a random order, so sometimes I just get a black screen instead of the Plymouth bootsplash. Running that command on boot via a script always switches back over to the Intel chip. –  thirtythreeforty Oct 26 '12 at 3:20

I got the same lappy. Please download the ubuntu certified iso. It's not the same one they put on the standard download page.

share|improve this answer
2  
The iso offered on the download page, is the official one, and there is no separate ubuntu certified iso. There are however different versions, for different architectures. The solution is to power off the graphics card. See the Ubuntu Community documentation on hybrid graphics for full details –  Mahesh Oct 12 '12 at 13:10

Enter your bios and change to 'switchable graphics' or 'fixed mode'.

Find a linux based ATI Radeon driver support from dell

share|improve this answer
    
Thank you for the answer. I've already tried finding an option in the BIOS, and couldn't find any option there. –  Mr Programmer Sep 26 '12 at 12:05
1  
We prefer answers that are detailed. Though this may work, it lacks enough detail to be of good use to future visitors. I suggest you expand the answer including detailed steps to accomplish the same, and include references/links to better-compatible drivers. –  Mahesh Oct 12 '12 at 13:15

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.