Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Using Ubuntu 12.04 Asus U43F

I can no longer update, install or remove packages via software center because of package dependency errors.

sudo apt-get install -f reads the following:

    Reading package lists... Done Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following packages were automatically installed and are no longer required:
  libunity6 libqapt-runtime libboost-program-options1.46.1
  akonadi-backend-mysql libqapt1 shared-desktop-ontologies libntrack0
  ntrack-module-libnl-0 libntrack-qt4-1
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
  krb5-multidev libk5crypto3:i386 libkrb5-dev
Suggested packages:
  krb5-doc krb5-doc:i386 krb5-user:i386
The following packages will be upgraded:
  krb5-multidev libk5crypto3:i386 libkrb5-dev
3 upgraded, 0 newly installed, 0 to remove and 325 not upgraded.
11 not fully installed or removed.
Need to get 0 B/213 kB of archives.
After this operation, 0 B of additional disk space will be used.
Do you want to continue [Y/n]? y
dpkg: error processing libk5crypto3 (--configure):
 libk5crypto3:amd64 1.10+dfsg~beta1-2ubuntu0.3 cannot be configured because libk5crypto3:i386 is in a different version (1.10+dfsg~beta1-2ubuntu0.1)
dpkg: error processing libk5crypto3:i386 (--configure):
 libk5crypto3:i386 1.10+dfsg~beta1-2ubuntu0.1 cannot be configured because libk5crypto3:amd64 is in a different version (1.10+dfsg~beta1-2ubuntu0.3)
dpkg: dependency problems prevent configuration of libkrb5-3:
 libkrb5-3 depends on libk5crypto3 (>= 1.9+dfsg~beta1); however:No apport report written because MaxReports is reached already

  Package libk5crypto3 is not configured yet.
dpkg: error processing libkrb5-3 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libgssapi-krb5-2:
 libgssapi-krb5-2 depends on libk5crypto3 (>= 1.8+dfsg); however:
  Package libk5crypto3 is not configured yet.
 libgssapi-krb5-2 depends on libkrb5-3 (= 1.10+dfsg~beta1-2ubuntu0.3); however:
  Package libkrb5-3 is not configured yet.
dpkg: error processing libgssapi-krb5-2 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libgssrpc4:
 libgssrpc4 depends on libgssapi-krb5-2 (>= 1.10+dfsg~); however:
  Package libgssapi-krb5-2 is not configured yet.
dpkg: error processing libgssrpc4 (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              No apport report written because MaxReports is reached already
                                            No apport report written because MaxReports is reached already
                          dpkg: dependency problems prevent configuration of libkadm5srv-mit8:
 libkadm5srv-mit8 depends on libgssapi-krb5-2 (>= 1.6.dfsg.2); however:
  Package libgssapi-krb5-2 is not configured yet.
 libkadm5srv-mit8 depends on libgssrpc4 (>= 1.6.dfsg.2); however:
  Package libgssrpc4 is not configured yet.
 libkadm5srv-mit8 depends on libk5crypto3 (>= 1.6.dfsg.2); however:
  Package libk5crypto3 is not configured yet.
 libkadm5srv-mit8 depends on libkrb5-3 (>= 1.9+dfsg~beta1); however:
  Package libkrb5-3 is not configured yet.
dpkg: error processing libkadm5srv-mit8 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libkadm5clnt-mit8:
 libkadm5clnt-mit8 depends on libgssapi-krb5-2 (>= 1.10+dfsg~); however:
  Package libgssapi-krb5-2 is not configured yet.
 libkadm5clnt-mit8 depends on libgssrpc4 (>= 1.6.dfsg.2); however:
  Package libgssrpc4 is not configured yet.No apport report written because MaxReports is reached already

 libkadm5clnt-mit8 depends on libk5crypto3 (>= 1.6.dfsg.2); however:
  Package libk5crypto3 is not configured yet.
 libkadm5clnt-mit8 depends on libkrb5-3 (>= 1.8+dfsg); however:
  Package libkrb5-3 is not configured yet.
dpkg: error processing libkadm5clnt-mit8 (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of krb5-multidev:
 krb5-multidev depends on libkrb5-3 (= 1.10+dfsg~beta1-2ubuntu0.2); however:
  Version of libkrb5-3 on system is 1.10+dfsg~beta1-2ubuntu0.3.
 krb5-multidev depends on libk5crypto3 (= 1.10+dfsg~beta1-2ubuntu0.2); however:
  Version of libk5crypto3 on system is 1.10+dfsg~beta1-2ubuntu0.3.
 krb5-multidev depends on libgssapi-krb5-2 (= 1.10+dfsg~beta1-2ubuntu0.2); however:
  Version of libgssapi-krb5-2 on system is 1.10+dfsg~beta1-2ubuntu0.3.
 krb5-multidev depends on libgssrpc4 (= 1.10+dfsg~beta1-2ubuntu0.2); however:
  Version of libgssrpc4 on system is 1.10+dfsg~beta1-2ubuntu0.3.
 krb5-multidev depends on libkadm5srv-mit8 (= 1.10+dfsg~beta1-2ubuntu0.2); however:
  Version of libkadm5srv-mit8 on system is 1.10+dfsg~beta1-2ubuntu0.3.
 krb5-multidev depends on libkadm5clnt-mit8 (= 1.10+dfsg~beta1-2ubuntu0.2); however:
  Version of libkadm5clnt-mit8 on system is 1.10+dfsg~beta1-2ubuntu0.3.
dpkg: error processing krb5-multidev (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of libkrb5-dev:
 libkrb5-dev depends on krb5-multidev (= 1.10+dfsg~beta1-2ubuntu0.2); however:
  Package krb5-multidev is not configured yet.
dpkg: error processing libkrb5-dev (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of libkrb5-3:i386:
 libkrb5-3:i386 depends on libk5crypto3 (>= 1.9+dfsg~beta1); however:
  Package libk5crypto3:i386 is not configured yet.
dpkg: error processing libkrb5-3:i386 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libgssapi-krb5-2:i386:
 libgssapi-krb5-2:i386 depends on libk5crypto3 (>= 1.8+dfsg); however:
  Package libk5crypto3:i386 is not configured yet.
 libgssapi-krb5-2:i386 depends on libkrb5-3 (= 1.10+dfsg~beta1-2ubuntu0.3); however:
  Package libkrb5-3:i386 is not configured yet.
dpkg: error processing libgssapi-krb5-2:i386 (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 libk5crypto3
 libk5crypto3:i386
 libkrb5-3
 libgssapi-krb5-2
 libgssrpc4
 libkadm5srv-mit8
 libkadm5clnt-mit8
 krb5-multidev
 libkrb5-dev
 libkrb5-3:i386
 libgssapi-krb5-2:i386
E: Sub-process /usr/bin/dpkg returned an error code (1)

I have tried to fix the broken dependencies via synaptic package manager, but it returns with an error:

E: libk5crypto3: libk5crypto3:amd64 1.10+dfsg~beta1-2ubuntu0.3 cannot be configured because libk5crypto3
E: libkrb5-3: dependency problems - leaving unconfigured
E: libgssapi-krb5-2: dependency problems - leaving unconfigured
E: libgssrpc4: dependency problems - leaving unconfigured
E: libkadm5srv-mit8: dependency problems - leaving unconfigured
E: libkadm5clnt-mit8: dependency problems - leaving unconfigured
E: krb5-multidev: dependency problems - leaving unconfigured
E: libkrb5-dev: dependency problems - leaving unconfigured

I haven't gotten help from ubuntuforums.org on this issue. Thanks in advance for any help.

share|improve this question
add comment

1 Answer 1

Try This. Just press Ctrl+Alt+T on your keyboard to open Terminal. When it opens, run the command below.

sudo dpkg --configure -a
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.