Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I recently installed Ubuntu 12.04 (after getting tired of Windows). Installation went fine.

I had one problem when I got in suspend mode and then resumed my screen was scrambled. After some googling founds some tips to upgrade my nvidia drivers. I did this, and rebooted but only a terminal windows appears now instead of a graphical desktop.

Tried to fix it by several reboots, and removing xorg.conf, but still no luck. Any advice how to fix it and get my desktop back ?

share|improve this question

2 Answers 2

up vote 11 down vote accepted
  1. After you've booted, press Ctrl+Alt+F1, and login using your credentials.

  2. Remove all the nVidia drivers that you installed.

    sudo apt-get --purge remove nvidia-*
    
  3. Install the drivers again:

    sudo add-apt-repository ppa:ubuntu-x-swat/x-updates
    sudo apt-get update
    sudo apt-get install nvidia-current nvidia-settings
    
share|improve this answer
    
Thanks,this did the trick! And also suspend/resume now works properly! –  user1613361 Sep 23 '12 at 9:27
    
This worked well enough for me to get workable video drivers back onto a machine that a user had made terminal-only by loading some drivers they found out about on a gaming site. This brought the computer back with a full desktop after an extended boot but there were immediate errors from Compiz and some other 'system problems' as well. I fired up the driver tool and swapped from the "current driver" to the first one on the list. Things were very snappy afterwards. I have to ask: Is using the x-swat repositories necessary? Wouldn't simply reinstalling from the regular repository work? –  Olympic Softworks - Dave May 8 '13 at 5:43
    
@OlympicSoftworks-Dave I really do not know. I recomment ubuntu-x-swat because they provide stable upstream releases of X.org components. –  green7 May 8 '13 at 8:11
  1. Open a Terminal (with Ctrl+Alt+T )

  2. Type this comment

    sudo unity --reset
    
  3. Wait.

  4. Restart. And you are done! :)
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.