Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Fresh install of 12.04

01:05.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI RS880 [Radeon HD 4200]

'Additional Drivers' shows ATI/AMD proprietary FGLRX graphics driver, and ATI/AMD proprietary FGLRX graphics driver (post-release updates) as not installed. ATI/AMD proprietary FGLRX graphics driver says it installs successfully when I try. The post-release updates say they fail (and when they fail the graphics driver no longer shows as installed either).

I did sudo apt-get install fglrx, which said it was already installed and sudo apt-get install fglrx-updates which installed something. I then restarted.

AMD control center is available and I can use it to get a dual monitor desktop working (which I cannot do with system settings -> displays).

Graphics performance is bad:

  • If I click and drag on the desktop the selection rectangle cannot keep up with the cursor and Xorg briefly uses a lot of cpu (observed in top).

  • Visiting eg youtube.com makes the chrome tab unresponsive and makes chrome use a lot of cpu

  • Scrolling in chrome is laggy.

  • I have seen compiz using a lot of cpu in top, but it also sometimes sits at around 4% (still at the top of the list but ok I guess?) it's at 45% right now.

I was running 12.04 in 2D desktop mode prior to this but was still having problems with eg scrolling in chrome, I was hoping a reinstall would help, but apparently not. What's the best way to resolve this? Get a new graphics card? try Mint instead? or is there a way to get this graphics card working happily with 12.04?

share|improve this question

1 Answer 1

I had EXACTLY similar problems. Here's what i did : I purged FGLRX install by using these commands :

sudo sh /usr/share/ati/fglrx-uninstall.sh

sudo apt-get remove --purge fglrx fglrx_* fglrx-amdcccle* fglrx-dev*

(if the first one does not work, it's normal, just use the second one)

Then i rebooted, went on AMD's driver download section, downloaded the drivers i needed, ran the .run drivers into a terminal and installed them. Rebooted, went into Catalyst Control Center>Display Settings>Tear free and checked activate tear free.

Then i went on compiz settings via CompizConfig (you may need to install it via Ubuntu's Software Center) clicked on OPENGL and unchecked Sync to VBlank and everything went fine.

share|improve this answer
1  
Thanks a lot for your answer. I followed your steps and things did not improve. I've found though that things are better (although not great) if I uninstall the AMD driver (with /usr/share/ati/fglrx-uninstall.sh), reboot and just leave the system like that. I don't know what graphics driver is being used now, but it seems to be doing a better job than amd's. –  fran Sep 23 '12 at 19:30
    
Are you sure you purged your FGLRX drivers corretly and installed the AMD drivers you need? –  D3s7 Sep 23 '12 at 21:56
1  
If you purged and removed FGLRX and no FGLRX package is installed and used, then the radeondriver is active. –  Uri Herrera Sep 24 '12 at 3:38

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.