Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm running Ubuntu 12.04. I installed netbeans 7.0.1 and subversion 1.16.17, both from the repositories. When I click on Team-Subversion-Checkout nothing happens. When I enter the path to executable /usr/bin in Tools-Options-Misc-Versioning-Subversion and click OK, the checkout still doesnt work. When I reenter the options menu the path is not there. Seems like it isnt saved.

share|improve this question
    
I managed to get the executable path in the field by editing the file ~/.netbeans/7.0/config/Preferences/org/netbeans/modules/subversion.properties. The path is now also shown in the GUI options menu. My subversion.properties looks like this: annotationFormat=[{status} {folder}] annotator.annotationExp.0=\\2 annotator.urlExp.0=.*/(branches|tags)/(.+?)(/.*)? autoOpenOutput=true excludeNewFiles=false prefixRepositoryPath=false svnExecBinary=/usr/bin –  user92102 Sep 22 '12 at 20:45
    
too be honest with you, netbeans svn plugin never worked for me, I am using git at the moment, and that works as a charm. You should consider using git. –  Dr_Bunsen Oct 31 '12 at 8:34
add comment

2 Answers

I've found a solution for this bug that happens just in netbeans installations that comes from debian repository packets, and it's related directly with permissions over some files in the installation, this is a work around to solve it:

Subversion plugin was not installed correctly so

  • run: sudo netbeans
  • uninstall subversion plugin
  • quit netbeans
  • run: netbeans (Note that now you're running it as a regular user not like root)
  • go to Tools->Plugins->[Settings]
  • add offical plugins repositories
  • change to "available plugins" tab and install subversion plugin

Hope it helps!

share|improve this answer
add comment

I've found a solution for this bug that happens just in netbeans installations that comes from debian repository packets, and it's related directly with permissions over some files in the installation, this is a work around to solve it:

Subversion plugin was not installed correctly so

-run: sudo netbeans 
-uninstall subversion plugin 
-quit netbeans 
-run: netbeans (Note that now you're running it as a regular user not like root) 
-go to Tools->Plugins->[Settings] 
-add offical plugins repositories 
-change to "available plugins" tab and install subversion plugin

Hope it helps!

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.