Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Dual boot Windows/Ubuntu.

  1. In Ubuntu, I cannot write the character '@'. When I try to do so, another character appears, so cannot email! Tried another keyboard, same problem - both are fine in Windows.

  2. Cannot access a "root" terminal. Searched for file menu.lst but cannot access it (in order to change default boot system). Please help. (Running Ubuntu 10.04 LTS / Windows XP)

share|improve this question
    
What character appears instead of @? It would also help to separate your questions into two posts. –  hexafraction Sep 22 '12 at 20:36
    
This is more than one question its bettet to seperate between –  user61928 Sep 27 '12 at 9:38

1 Answer 1

As for the root terminal -- as have been pointed out, open a regular terminal (press Win key, type "terminal", enter), and type sudo -i, then your own password. But beware, you can trash your system as root if you don't know what you are doing.

Something must be wrong with your language / keyboard settings.

  1. What physical keyboard are you using? US, German, ...?
  2. Go to System -> Preferences -> Keyboard to open the Layouts tab. Move the appropriate layout to the top.
    (in 12.04 - press the "Win" key, type "keyboard layout", Enter. Make sure that your layout matches your physical keyboard. There is a little icon of a keyboard below the options. If you click it, you will see what the chosen layout is. I assure you that the @ key is there, waiting for you to get pressed)

10.04

enter image description here

12.04

enter image description here

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.