Sign up ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

When setting the channel to wlan0, I get an error:

SET failed on device wlan0 ; Device or resource busy.

I tried to shutdown wlan0 by:

sudo ifconfig wlan0 down

and wlan0 did not appear in the ifconfig result, but I still get the error when I use this command to switch channels:

sudo iwconfig wlan0 channal 1

The funniest thing is I just used this method to change channal from 4 to 6, and now I want to change the channal from 6 to 1, but I can't finish it. Did I miss something?

share|improve this question
I think that the main problem is that you are typing "channal", instead of channel. – Braiam Aug 12 '13 at 13:46

1 Answer 1

you may try my script... ;-)

to download the file click here:

then save it and make it executable by "chmod +x wc". You then execute it by "./wc"

share|improve this answer
Please, that's not a script but application/octet-stream. Scripts should not have this kind of mime type. – Braiam Aug 12 '13 at 13:43
Why don't you just paste your script inside your answer? – Alvar Aug 12 '13 at 13:44
The relevant part of his script seems to be this: ifconfig $1 down ; iwconfig $1 mode managed ; ifconfig $1 up ; iwconfig $1 channel $2 ; ifconfig $1 down ; iwconfig $1 mode monitor ; ifconfig $1 up; But it didn't work for me. – phord Aug 25 at 15:44

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.