Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I got two OSes in my PC, Ubuntu and Windows 7.

Until yesterday Windows 7 was on top of my dual-boot menu list, but I wanted to change it, so I went inside Windows configurations and put Ubuntu first, but I also set the time to 0 because I thought I could access Windows through Grub.

But what happens is that after I upgraded Ubuntu to 11.10, that screen with boot options don't show Windows 7 anymore.

I went online searching for a solution to my problem, most of them told me to configure some Grub options and others to use programs to do it. I've done them all and still can't access Windows 7.

Just in case my problem is not clear yet, this is how was my boot order before I messed it all up:

Windows 7
Ubuntu

with a time of 10 secs to choose between both.

This is how I wanted it to be:

Ubuntu
Windows 7

with 0 time to choose, but, inside Ubuntu I could access Windows through that Grub screen.

But this is what happens:

Ubuntu
Windows 7

0 time, so it don't let me choose anything and jumps inside Ubuntu then inside Ubuntu grub doesn't show up anymore (black screen) and it starts Ubuntu normally.

I tried to fix this many times from different ways inside Ubuntu but nothing worked, also when I try do something and then upgrade my grub with sudo upgrade-grub it shows this message:

Generating grub.cfg ...
Found Windows 7 (loader) on /dev/sda1
Skipping Windows 7 (loader) on Wubi system
Found linux image: /boot/vmlinuz-3.0.0-12-generic
Found initrd image: /boot/initrd.img-3.0.0-12-generic
Found linux image: /boot/vmlinuz-2.6.38-12-generic
Found initrd image: /boot/initrd.img-2.6.38-12-generic
done

Thats why in the title I said it could probably be my WUBI messing all up.

Anyone heave a solution for this? Do you need more information?

I have a netbook so I cannot use the Windows Repair CD.

share|improve this question
    
Just use gksudo gedit to edit your boot.ini in /host, assuming you are using Wubi. –  hexafraction Sep 22 '12 at 17:45
    
I am using Wubi however when I use command gksudo gedit the file does not load in the text editor –  Chris Sep 24 '12 at 1:48
    
You open Gedit with the command, and then open the file ith File>Open. Go into File System, host, and boot.ini. –  hexafraction Sep 24 '12 at 10:40
    
This is a common misconception and problem among Wubi users. With XP you can fix it through the boot.ini but for Vista/Windows 7 you need a Windows repair CD (or the install DVD). Then run bcdedit /timeout 10 from the Windows repair prompt –  bcbc Oct 19 '12 at 10:19
add comment

1 Answer

Press Alt+F2, type gksudo gedit /etc/default/grub press Enter and enter your password. You will see the following contents:

GRUB_DEFAULT=0
GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=lsb_release -i -s 2> /dev/null || echo Debian
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""
 

  • You can change the default from 0 to any number, corresponding to the entry in the Grub bootup menu (first entry is 0, second is 1, etc.)
  • You can change the "hidden timeout" (no menu); and also display the countdown (TIMEOUT_QUIET=false)
  • You can force the grub menu to show by commenting out the two GRUB_HIDDEN lines with a # at the beginning of the line
  • And set the grub menu timeout (default is 10 seconds)

  • Make your changes, press Ctrl+S to save and Ctrl+Q to exit. This will change your timneout
    To change the order of your OS menu go to the directory /etc/grub.d

In this directory change the prefix of the Windows7 and make it less than of the Ubuntu one
- Important: Open a terminal with Ctrl+Alt+T and type sudo update-grub to apply the changes you just made. - Reboot and you should see your timeout/default entry change.

share|improve this answer
    
That will change the grub timeout, however Windows 7 does not show up in the grub menu. I need t be able to re-access the windows MBR in order to get into windows 7. –  Chris Sep 24 '12 at 12:07
    
No its not true when you change the Timeout then you have time to choose the OS you want to boot from when theGrub2 menu appears –  user61928 Sep 24 '12 at 13:06
    
The Grub 2 menu does not have an option for windows. This is why I have been so stumped. –  Chris Sep 25 '12 at 0:53
    
Does anyone need to fix my issue? –  Chris Sep 28 '12 at 3:25
    
The grub menu doesn't have an option to boot Windows because it's bypassed for Wubi installs... because with Wubi you boot via the Windows boot manager (which you forced to go straight to Ubuntu), and grub only appears after that point. Even if you had the Windows entry in grub it wouldn't make any difference. –  bcbc Oct 19 '12 at 10:22
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.