Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Possible Duplicate:
My computer boots to a black screen, what options do I have to fix it?

I installed Lucid Lynx over PXE onto this dell server seemingly successfully, but booting from the HD results in a black, unpowered screen. There appears to be no network connectivity to the box either. It may have landed at a textual busybox type prompt, but I can't see it. Ctrl-Alt-Delete seems to reboot.

On my last attempt I held shift and the grub menu came up, but recovery mode produced the same results.

Should I drop into the grub prompt and give the kernel a magical boot option? Should I boot from a rescue cd and munge some bits on the HD? Give up and install windows?

share|improve this question
    
Have you removed the quiet option from grubs kernel commandline? If not, try to boot without quiet and splash. You'll see some output. –  qbi Aug 11 '10 at 7:48
2  
Could you change your subject to something like 'Lucid Lynx ..'. When I read lynx I'm thinking of the application lynx and not Ubuntu 10.04. –  qbi Aug 11 '10 at 8:15
    
I think of the animal from my 5th grad animal report! –  myusuf3 Aug 11 '10 at 13:38
add comment

marked as duplicate by Jorge Castro, Eliah Kagan, jokerdino, John S Gruber, maythux Oct 5 '12 at 7:57

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

3 Answers

up vote 4 down vote accepted

Here are a couple of "magical boot options" to try:

  • nomodeset
  • i915.modeset=0 xforcevesa

I'd remove quiet splash when trying these and only one at a time, not together as they'll likely conflict.


Edit: for an explanation of how to use these:

  • When booting, hold left-Shift
  • Highlight the first option and press e
  • Go down to the line that looks like:

    /boot/vmlinuz-3.0.blah-generic root=UUID=blah ro quiet splash
    
  • Replace quite splash with your boot option of choice.

If that works out well, you can make the changes to /etc/default/grub by editing the GRUB_CMDLINE_LINUX_DEFAULT value. After saving, run sudo update-grub.

share|improve this answer
    
thank you for your options. before I saw your answer I used the ubuntu pxe rescue to install nvidia-latest, which eventually resolved my issue. Dell Precision T3500 –  Ron Aug 11 '10 at 21:14
add comment

It is likely to be related to plymouth/mountall check the following blog entry for some tips: http://handypenguin.blogspot.com/2010/04/when-recovery-mode-fails-to-boot.html

share|improve this answer
add comment

I get a black screen too, but if you are patient it will give you option to choose current OS or Ubuntu, click down arrow to Ubuntu and press enter. Grub will come up, leave default and then password box to sign in. You are there! But must warn you, it will go to default OS if you miss it. The minute you boot, don't turn your head or it will be gone. LOL

share|improve this answer
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.