Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have tried sudo apt-get install -f and then sudo apt-get update

but I still have the same dependency problems:

dpkg: dependency problems prevent configuration of google-chrome-stable:i386:
google-chrome-stable:i386 depends on xdg-utils

And idea how to fix it?

BTW, when I use sudo apt-get install -f, I got an output:

After this operation, 119 MB disk space will be freed.
Do you want to continue [Y/n]? y

which seems to remove the files.

share|improve this question
4  
The version in the repositories is out of date. It is best to download the .deb from the official Google chrome site: installing that deb also adds the Google repository, which will keep it up to date. –  user76204 Sep 22 '12 at 16:55
    
hi mik: i do download from the official site, which i believe is the latest version.@Mik –  Nathan Sep 22 '12 at 19:03
    
@Mik I can confirm the problem: - fresh installation of 12.04.1 done today in 64 bit version - downloaded chrome 32 bit deb package at www.google.com/chrome/ - double clicking on the deb file or launching dpkg - i google-chrome-stable_current_i386.deb fails with the error dpkg: dependency problems prevent configuration of google-chrome-stable:i386: google-chrome-stable:i386 depends on xdg-utils descibed originally –  maximd Sep 23 '12 at 20:00
    
@maximd and Nathan I should try installing the 64 bit .deb of Chrome if you are running a 64 bit system. –  user76204 Sep 23 '12 at 20:31
1  
@Mik I am running a 32-bit system, I am quite sure on that. –  Nathan Sep 30 '12 at 20:14

3 Answers 3

As maximd's comment under your question has shown, the same error as yours occurs when trying to install 32 bit Chrome under a 64 bit Ubuntu system. These i386 error message always occurs when it is an architecture problem. In contrast, I successfully installed the same 32 bit deb on a 32 bit system today, so the issue is not due to a bad version of Chrome.

The architecture error is well known, as documented in a similar question at Superuser where similar dependency issues are discussed. On account of Ubuntu's multiarch feature (which enables the user to install 32 bit packages on 64 bit systems) these sorts of errors don't occur very regularly now, but are still possible. Sometimes it is still necessary to use the 64 bit version of the package.

There is no point in forcing the installation with something like sudo dpkg -i --force /location/of/deb, as that will not solve the dependency issues, so I should just remove the partial installation of Chrome with sudo apt-get install -f and install the 64 bit deb from the Google Chrome site with gdebi or Software Center, which will resolve the dependencies as well.

share|improve this answer
    
to be honest I did not try 64 bit version of Chrome because - from what I remember - the 64 bit version does not (cannot?) integrate flash (I mean, the flash version bundled with Chrome). Though I just stumbled upon this superuser.com question about "Flash player not present in Chrome on Ubuntu 12.04 64-bits" and it seems that the solution for flash support in chrome 64 bit is to install flash through the ubuntu repositories/software center –  maximd Sep 24 '12 at 12:27
    
I found this post by google and It is useful for me :) –  user1022209 Nov 17 '12 at 8:36

This is caused by bug #992797.

It's not due to the version number but the lack of Multi-Arch support in the xdg-utils package. I was able to successfully install Chrome without --force-depends by adding Multi-Arch: foreign to the DEBIAN/control file for xdg-utils and rebuilding that package with dpkg-deb, but of course this still leaves apt-get dist-upgrade broken because the repositories have a broken version.

Update: If you add an epoch to the version, it will fix apt-get. So the full workaround is:

apt-get download xdg-utils
dpkg-deb -R xdg-utils*.deb xdg-utils
patch xdg-utils/DEBIAN/control # (paste in the patch below)
fakeroot dpkg-deb --build xdg-utils xdg-utils-hacked.deb
sudo dpkg -i xdg-utils-hacked.deb

patch:

--- xdg-utils.orig/DEBIAN/control   2011-10-04 00:49:41.000000000 -0400
+++ xdg-utils/DEBIAN/control    2012-11-30 16:24:15.365170233 -0500
@@ -1,6 +1,7 @@
 Package: xdg-utils
-Version: 1.1.0~rc1-2ubuntu6
+Version: 1:1.1.0~rc1-2ubuntu6
 Architecture: all
+Multi-Arch: foreign
 Maintainer: Ubuntu Developers <[email protected]>
 Installed-Size: 316
 Recommends: libfile-mimeinfo-perl, x11-utils, x11-xserver-utils
share|improve this answer
    
Don't use an epoch like that or you won't ever get updates for xdg-utils. –  Jeremy Bicha Nov 30 '12 at 22:43
    
Agree. You should tell your package management to hold that specific version instead. +1 for pointing+commenting at bug report, though. –  gertvdijk Dec 5 '12 at 16:10

I'm not 100% sure about this, but here is my guess: chrome depends on xdg-utils >= 1.0.2, but you have installed 1.1.0~rc1-2ubuntu6 (at least I have this on my linux mint 13 64 bit).

Somewhere there is a misunderstanding that leads apt to believe your 1.1.0 rc1 version is earlier than 1.0.2, thus not satisfying the dependency.

If I'm right the problem will disappear as soon as xdg-utils will have a final version number. In the meanwhile I personally enjoy a flawlessly running Chrome installed with dpkg -i --force-depend.

share|improve this answer
    
I don't believe in "misunderstandings" in apt for a simple version number comparison. If that would be the case a lot more would be broken. –  gertvdijk Dec 5 '12 at 16:06

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.