Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Using Ubuntu 12.04 on old used to be XP desktop now dedicated to Ubuntu. Printer is Canon MX320. Had been running it on my other desktop and laptop thru a switch. No problem. Want to eliminate the Win7 box and use the Linux and the Canon printer. Unable to print anything. Any suggestions would be appreciated.


I get to localhost:631, add printer and asks for my username, put it in, then password but it does not recognize it. ?? just reverts back to the ask username/password box.


OK I got through the login but it could not find my printer (MX320). All it found was similar models as PIXMA 300, 330. Thay did not work. It did show up in the print queue but no activity.

share|improve this question

2 Answers 2

Problem solved. I did use CUPS but the problem was with that I was going through an IO Gear printer switch. When I connected the computer directly to the printer, it worked. So now I am looking for a USB cable that has two true Y male ends if that's possible so I can attach my other computer to the printer.

share|improve this answer

Have you tried to configure the printer through CUPS?

You can access the interface by web browser - localhost:631.

Choose "Adding Printer and Classes".

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.