Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Possible Duplicate:
How to completely remove desktop?

So, I thought I managed to remove KDE completely, but apparently that did not work at all, because every KDE application is back, including the KDE splash screen.

I ran

sudo apt-get autoremove --purge kubuntu-desktop

Then I ran

sudo apt-get install --reinstall ubuntu-desktop

Then I ran

sudo sudo update-alternatives --config default.plymouth

Then I rebooted and everything seemed to be the original ubuntu-desktop (without the kde splash screen and other KDE applications). But now, one week later I still boot to ubuntu-desktop, but like I said, the kde splash screen and applications are all back.

How should I remove kubuntu-desktop?

share|improve this question

marked as duplicate by jokerdino, Jorge Castro, Tom Brossman, Jjed, Takkat Sep 22 '12 at 19:00

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
@Meijuh just follow the link provided by penreturn and get your cemented desktop remove. –  Namshum Sep 22 '12 at 11:38

1 Answer 1

Probably you have to delete each dependency by hand:

apt-cache depends kubuntu-desktop

These scripts should work for 12.04: www.psychocats.net

share|improve this answer
    
Well I did just that and now i am getting the following error. Unpacking libqtcore4 (from .../libqtcore4_4%3a4.8.1-0ubuntu4.2_amd64.deb) ... dpkg: error processing /var/cache/apt/archives/libqtcore4_4%3a4.8.1-0ubuntu4.2_amd64.deb (--unpack): conffile './etc/xdg/Trolltech.conf' is not in sync with other instances of the same package Errors were encountered while processing: /var/cache/apt/archives/libqtcore4_4%3a4.8.1-0ubuntu4.2_amd64.deb –  Meijuh Sep 22 '12 at 12:31
    
After issueing apt-get install -f, I got broken packages, because libqtcore4 would not install. Magically, I was able to remove libqtcore4 via synaptic and then reinstall it via apt-get. –  Meijuh Sep 22 '12 at 12:40
    
So - does it work now? And do you think it is an issue caused by one of the scripts mentioned in the link above? –  Sebastian vom Meer Sep 25 '12 at 16:26

Not the answer you're looking for? Browse other questions tagged or ask your own question.