Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am using a Dell laptop with Windows 7, all of a sudden the HDD is not recognized by Win7. I wanted to backup the data in Windows, so I made a Ubuntu 12.04.1 Live CD, and booted from it. I am using Ubuntu without installing it in my laptop.

My problem is that I don’t see the Windows partitions in Ubuntu 12.04.1, because of which I am unable to backup the data. Any suggestion in this regard would be very helpful.

PS: I checked the SMART status of the HDD it says 2 Bad sectors, when I attempted an extended Self-Test, I get a Read Failed message, though the Short test goes through fine.

Thank You, Siva

share|improve this question
    
Voters... The question has a viable upvoted answer, so it shouldn't get closed as 'too localized`. –  Basharat Sialvi Jun 5 '13 at 2:13
    
@BasharatSial Not so sure it's viable. Mounting read only is useful e.g. in the case of hibernation, but you should get an error from the rw mount in that case. There doesn't appear to be any feedback and it's not accepted, and for an unmountable partition something like photorec would probably be more suitable. –  bcbc Jun 5 '13 at 6:13
add comment

2 Answers 2

It seems most likely that the hard drive and the file system is damaged and it is not possible to mount the drive in the normal way. The Ubuntu LiveCD will have no problems reading a good NTFS partition - it will be accessible through Nautilus File manager.

If the Windows file system does not show up in Nautilus, try mounting the drive as read only. Open a terminal window and type:

sudo mount -r -t ntfs /dev/sda1 /mnt

(replace /sda1 by the name of your Windows partition, you can check it via 'sudo blkid' or 'sudo parted -l')

If this works with no errors you can then access your data in terminal or Nautilus under the directory /mnt, for example

cd "/mnt/Documents and Settings/yourusername/Documents"

and so on. If you use terminal (bash) then be aware that Linux is case sensitive. If you type 'documents' instead of 'Documents' it will not work.

You will not be able to modify anything on the hard drive because it will be mounted read only. This is a good thing given the current state of the drive. You will need another hard drive with enough capacity make your backup on.

Good Luck!

If the mount works but the contents of /mnt don't look right, it might be because it's the wrong partition (the above assumes windows installed on the the first (sda1) partition. If you can't find the correct partition then paste the output of the following bash command here:

sudo fdisk -l

so that we can have a look.

share|improve this answer
add comment

Windows 7 is using NTFS partition. By Default this kind of partitions are RECOGNIZED by ubuntu. If for anycase it doesn't recognize them You should try to install them if you can reach internet from ubuntu live cd using the following command: sudo apt-get install ntfs-config

Another solution is to download Gparted live cd or Hiren's Boot CD

share|improve this answer
    
check this article https://help.ubuntu.com/community/MountingWindowsPartitions –  user91632 Sep 22 '12 at 10:08
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.