Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

As the title suggests, I'd like to force Deja Dup to use a folder other than /tmp.

My backups fail due to size size restrictions, see bug: https://bugs.launchpad.net/deja-dup/+bug/1033552

Any help will be greatly appreciated.

Thanks in advance.

share|improve this question
    
Still sitting without a backup solution. Any help that solves the question will be greatly appreciated. –  Brendan Oct 1 '12 at 14:59
1  
possible duplicate of Backup no longer working –  hhlp Dec 28 '12 at 17:03

2 Answers 2

The above solution works, but is generally not a really good option if you just want to change the tmp-Folder of the deja-dup process! Also I wouldn't sacrifice tmpfs because of this issue.

Since deja-dup uses duplicity as its backend to make the actual backup, the problem has to be solved for duplicity. Duplicity uses the environmental variable TMPDIR which normally points to /tmp

To change the location of the TMPDIR for duplicity (deja-dup), simply open the terminal and run:

TMPDIR=/othervolume/otherfolder
export TMPDIR
deja-dup-preferences
share|improve this answer

1.disable tmpfs:

sed -i "s/^\(RAMTMP\=\).*/\1no/" /etc/default/rcS

2.reboot

3.make a new temp dir in the partition that have more space. eg I will use the home dir with the appropriate permissions for read and write, and made a symbolic link to /tmp

mkdir /home/tmp
chmod ugo+rw /home/tmp
ln -s /home/tmp /tmp

share|improve this answer
1  
Thanks for your reply, however I DO NOT want to stop using tmpfs, rather I want to change the location that deja dup uses. I get a major performance boost using tmpfs and don't want to sacrifice that just to use deja dup. –  Brendan Sep 23 '12 at 4:24

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.