Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Possible Duplicate:
How do I disable overlay scrollbars?

By default 12.04 uses overlay scroll bars that are too difficult to click and make it harder to see my relative position, and every method I've found so far of disabling them makes them broken in a different way.

When I was using 11.10 this wasn't a problem because I could still change the GTK theme. In 12.04, the Appearance settings only contain a few stock themes, and other than the special purpose contrast ones they all have the overlay scroll bars. If I aptitude search gtk3 | grep theme I get no results so there appears to be no packaged alternative either.

Most suggestions I've seen for disabling the overlay scroll bars involve uninstalling packages or editing files as root. I want to disable them just for the current user, not for everyone on the whole box; as should be the case for any theme/display setting.

There is a gsettings command that temporarily disables the overlay scrollbars just for the current user, but this has two problems of its own:

  1. The setting doesn't stick after log off. Because who would want to save settings?
  2. The scroll bars put in place have no contrast. They have a black scroller on a black background and are completely unusable.

In short what I'd like to know is how to disable overlay scroll bars such that:

  • My preference is user specific.
  • My preference is actually saved.
  • The scroller can actually be seen against the background without having to use a special high contrast theme that makes my whole desktop look like a negative photo from Tron.
share|improve this question

marked as duplicate by Anwar Shah, January, Uri Herrera, jokerdino, hbdgaf Sep 22 '12 at 9:41

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
The last of your three points is doable on a user-specific basis. If you are interested, please modify your question accordingly. –  user25656 Sep 22 '12 at 7:29
1  
You don't need to change the theme. Just follow the instruction in the above link for per user case –  Anwar Shah Sep 22 '12 at 8:06
    
My question is *not * an exact duplicate. None of the earlier posts address the combination of my last 3 points. If there is a post that does please actually link it instead of just closing my post. –  Joseph Garvin Sep 22 '12 at 14:14

1 Answer 1

Go into terminal and type this line:

gsettings set org.gnome.desktop.interface ubuntu-overlay-scrollbars false

which will disable the overlay scrollbars, although you could completely remove them from the system by typing this command (overkill):

sudo apt-get purge "scrollbar*"
share|improve this answer
    
You would need to re-login for the change to take effect referred to this link: tuxgarage.com/2012/05/… –  user91632 Sep 22 '12 at 8:08
    
The gsettings trick still leaves me with totally unusable scroll bars, as mentioned in my post. They're black on black and obviously were never tested before release. –  Joseph Garvin Sep 22 '12 at 14:14

Not the answer you're looking for? Browse other questions tagged or ask your own question.