Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have ubuntu 12.04 installed with virtualbox 4.1.12. I have a windows 7 professional 32-bit virtualmachine with a bridged network adapter inside virtualbox. I've given a static ip to this machine with all ports open on both host and virtual machine (for now) but people outside of my network can't remote into the virtual machine, just the host. If they are on my network they're able to remote in just fine.

What am I missing to allow the outside connections into the virtual machine (remote display was way too slow).

Host's internal ip: 192.168.2.151 port: 3389 --- Virtual Machine's internal ip: 192.168.2.155 --- port: 10155

share|improve this question
add comment

3 Answers

First enable remote display in virtual box settings then try again using a remote client such as Remmina enter image description here

share|improve this answer
    
That doesn't accomplish what I'm after. Remote display is incredibly slow, I'd rather remote into the virtual machine itself. I can use the built in windows remote desktop application to remote into my virtual machine on my network, but anyone outside of my network can't; they can only remote into the host. Any other ideas I could try? I've also tried disabling any firewalls on ubuntu 12.04. –  krone6 Sep 22 '12 at 6:19
add comment

People outside your network cannot reach your host using the private IP you given (192.168.2.151) because it's an internal IP, they use the public IP address to do so.

If you want to let outside people have access to your virtual machine you should give it another ip which is at the same range of your host public IP.

the second solution would be to allow them to enter your local network using VPN and then connect to the virtual machine using the private IP 192.168.2.155

share|improve this answer
    
I never gave anyone 192.168.2.155, I used that ip because it's the static ip assigned to that host internally. When i have someone outside try to connect it'll either be through to ddns on the machine or the ip i have coming in. It'll both work if i try to remote into the host, but not the virtual machine. If i were to do [my external ip]:10155, it'd not work but if i just did [my external ip] it would, since the host is using port 3389. Even with a bridged adapter they still can't reach my virtual machine. And I could dp a VPN, but i know there's other ways as well. –  krone6 Sep 22 '12 at 7:19
add comment

Try changing the virtual network interface to "NAT" type in VBox, then just use port forwarding on your router to jump in.

share|improve this answer
    
@user Setting it to NAT makes the host machine act as a NAT router for the guest. To be accessed like a machine on the physical LAN, the virtual machine's interface should be set to Bridged. –  Eliah Kagan Dec 30 '12 at 4:00
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.