Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am trying to install Ubuntu 12.04 LTS on my Inspiron laptio, but the installer does not show any drives. My system has a 1TB SATA drive and a 32GB SSD. As far as I can figure, the boot files are kept on the SSD for fast startup (for Windows). During Win7 installation, I had to manually load drivers for RAID controller to see all available drives. Running fdisk -l from the live CD shows the following:

ubuntu@ubuntu:~$ sudo fdisk -l

Disk /dev/sda: 1000.2 GB, 1000204886016 bytes
255 heads, 63 sectors/track, 121601 cylinders, total 1953525168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x234b4782

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1              63       80324       40131   de  Dell Utility
/dev/sda2   *       81920    41627647    20772864    7  HPFS/NTFS/exFAT
/dev/sda3        41627648   357019647   157696000    7  HPFS/NTFS/exFAT
/dev/sda4       357019648  1953517567   798248960    f  W95 Ext'd (LBA)
/dev/sda5       672415744  1312966655   320275456    7  HPFS/NTFS/exFAT
/dev/sda6      1312968704  1953517567   320274432    7  HPFS/NTFS/exFAT

Disk /dev/sdb: 32.0 GB, 32017047552 bytes
255 heads, 63 sectors/track, 3892 cylinders, total 62533296 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x234b474b

   Device Boot      Start         End      Blocks   Id  System
/dev/sdb1            2048    16775167     8386560   84  OS/2 hidden C: drive

In the Ubuntu installer, I can only choose /dev/sdb for "Device for boot loader installation", and sdb doesn't show any drives. I cannot select /dev/sda.

Any ideas anyone?


share|improve this question

I had the exact same problem with my Dell Inspiron 14z. I removed the RAID info on sda explained in this answer. It worked for me, without destroying the current Windows 7 installation. The SSD seems to be used for hibernate/sleep in Win7, and that still works after removing the RAID info.

It might be possible to install ubuntu on the SSD (sdb), but I could not find the disk in the partition step during installation, so I installed on sda.

share|improve this answer

Solution tl;dr: delete software RAID containers during manual partitioning (works in Ubuntu 14.04 LTS)

I had a similar problem with a drive that had been part of a RAID array. It would not show up in the partitioner. I dropped into a recovery shell and deleted all its partitions and still it would not show up. Finally I tried the 'Configure software RAID' and destroyed the containers that it found (I was completely repurposing this drive so didn't care about any data left on it.) After dropping back to the 'detect hardware' stage, it picked up the drive and I was able to proceed normally.

I would hazard a guess that completely zeroing out the drive would work too (i.e. dd if=/dev/zero of=/dev/sdX bs=1Muntil it runs out of space) but this is a lot slower.

share|improve this answer
It would probably be enough to erase the header in the first megabyte of the drive: dd if=/dev/zero of=/dev/sdX bs=1M count=1 – David Foerster Jan 12 '15 at 16:06
Yes, probably, but I don't know enough about how the RAID metadata is stored to be able to say definitively. – David G Jan 12 '15 at 17:23

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.