Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

How to limit xen dom0 RAM to a certain amount?

When there was grub1 and a grub.cfg, I knew how, just add to the kernel options there.

Now I have no clue. I have tried setting GRUB_CMDLINE_LINUX_DEFAULT="nomodeset dom0_mem=640M,max:640M" in /etc/default/grub but no effect, dom0 still uses all RAM.

share|improve this question

The line you have to add in /etc/default/grub is:



share|improve this answer
and also set (dom0-min-mem 640) in /etc/xen/xend-config.sxp – milan Sep 16 '13 at 15:01

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.