Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

i have a problem with my sound in ubuntu 12.04(64bit). the problem is, that sometimes out of nowhere, when switching songs, or playing youtube videos, changing volume with my keyboard buttons, that the sound gets distorted(peeping, scratching). i dont know if it is related, but when i skip through music in rythmbox, there is also a little scratching noise.

i can sometimes temporarly fix it: for youtube videos, i refresh the page, and sometimes it works agian normal, mostly not. for audio playback with rythmbox, i have to pause the song for sometime, and resume it, and hope that it works.

before all that,i have changed my soundcard to "Analog Surround 5.1" in the sound settings from ubuntu, but i also used alsamixer to change it from 2 channels to 6 channels, since changing in ubuntu sound settings alone wasnt enough to make the other speaks work.

i use a ASUS P8-H61-M LE B3 Revision Motherboard. which has a built in surround soundcard. here is lshw -c multimedia output:

Beschreibung: Audio device
Produkt: 6 Series/C200 Series Chipset Family High Definition Audio Controller
Hersteller: Intel Corporation
Physische ID: 1b
Bus-Informationen: pci@0000:00:1b.0
Version: 05
Breite: 64 bits
Uhr: 33MHz
Fähigkeiten: pm msi pciexpress bus_master cap_list
Konfiguration: driver=snd_hda_intel latency=0
Ressourcen: irq:43 memory:f7f00000-f7f03fff    
share|improve this question
    
Odd... I've never had an issue with snd_hda_intel. Let me see if I can find the configuration options for you. –  Githlar Oct 12 '12 at 5:05
add comment

3 Answers 3

When the ALSA driver are loaded, it does a BIOS probe to try to figure out what version of the sound card you have. It's possible that perhaps the BIOS is either misdetecting or not detecting the card and using a generic model. So, in order to try out the other models you have to force the models with modprobe.

Try adding the following line to /etc/modprobe.d/alsa-base.conf (at the bottom):

options snd-hda-intel model=asus

The models listed in the ALSA documentation that may be pertinent to you are:

  • asus: 3-jack (ASUS mobo)
  • asus-w1v: ASUS W1V (Probably doesn't apply to you)
  • asus-dig: ASUS with SPDIF output
  • asus-dig2: ASUS with SPDIF output (using GPI02)

Others you might try:

  • 3stack: 3-jack in back and a headphone out
  • 3stack-digiout: 3-jack in back, a HP out and a SPDIF out
  • 5stack: 5-jack in back, 2 jack in front
  • 5stack-digiout: 5-jack in back, 2 jack in front, a SPDIF out
  • 6stack: 6-jack in back, 2 jack in front
  • 6stack-digiout: 6-jack in back with a SPDIF out

Experiment with those (as they apply to your motherboard) and let me know how it turns out. I can update my answer if need be.

share|improve this answer
add comment

After days with that problem and google it, I fixed with this link https://wiki.archlinux.org/index.php/PulseAudio#Glitches.2C_skips_or_crackling

share|improve this answer
    
Welcome to Ask Ubuntu! Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. –  Oyibo Nov 30 '12 at 13:59
add comment

Try sed 's/; default-sample-rate = 44100/default-sample-rate = 96000/g' -i /etc/pulse/daemon.conf

That and sudo gedit /etc/pulse/default.pa and adding tsched=0 to load-module module-udev-detect so it becomes load-module module-udev-detect tsched=0 solved the issue for me.

For reference, the commands were put to my attention at https://wiki.archlinux.org/index.php/PulseAudio#Glitches.2C_skips_or_crackling.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.