Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I recently ran updates and it told me that in order to get those updates I had to update my kernel. I did that and also updated Firefox to 15. Since then Firefox hangs/gray screens sites I go to. This lasts anywhere from 5-10 seconds to 2-3 minutes.

I have restarted Firefox with all add-ons disabled but it still did the same thing. I found a bug report on Launchpad that sounded like what was happening with me, but I haven't received any error codes, just the hanging/frozen screens. Also it seems that it ups my CPU making the rest of Ubuntu lag while Firefox is hung.

I would guess the cause is a conflict between the updated kernel and the updated Firefox, but I'm still fairly new at Ubuntu and not sure where to go from here. Is there anything else to try?

My Toshiba laptop specs are:

  • Ubuntu 12.04 (32 bit)
  • Linux 3.2.0-30-generic-pae #48-Ubuntu SMP Fri Aug 24 17:14:09 UTC 2012 i686 i686 i386 GNU/Linux
  • Firefox 15.0.1
  • Intel® Pentium(R) Dual CPU T3400 @ 2.16GHz × 2
  • Mobile Intel® GM45 Express Chipset x86/MMX/SSE2

Thanks!

share|improve this question
    
You can give reinstalling firefox a try, by running this command sudo apt-get install --reinstall firefox. –  Dan Sep 21 '12 at 15:04
    
I reinstalled Firefox, but that didn't help. It still hangs like before. Can I just downgrade Firefox back to the one that worked? –  Marty Sep 21 '12 at 15:27
add comment

2 Answers 2

up vote 2 down vote accepted

You can try reseting Firefox.

The easy way

In the menu press Help --> Troubleshooting Information.
In the top right, there will be a reset button.

It will keep your essential data like saved passwords, and bookmarks intact. But sync accounts, modified preferences, about:config modifications will be reset.

The Less easier way

Quit Firefox and run firefox -P. This will run Firefox's profile manager.
Create a new profile, and use it to test out Firefox.

Using this approach, is like installing a fresh copy of Firefox. So all passwords, history, settings, etc... that are saved in the default profile, will not be available in this profile.

To go back to the default profile, just quit Firefox and run firefox -P again, and choose your default account.

share|improve this answer
    
It looks like reseting Firefox the easy way fixed it. I have been browsing for a little while since doing that and haven't had any hang ups or problems. I also reinstalled my previous add-ons (ran a while without them and running with them, no problem). Thanks so much. If it starts again, I'll edit this to reflect that. –  Marty Sep 21 '12 at 18:27
add comment

disable flash player plugin and try to surf the web to see if it hangs again

click on firefox menu -> Addons -> Plugins -> disable Shockwave Flash

then close and restart Firefox

share|improve this answer
    
Disabling Flash didn't work. I also tried disabling other plugins, but it still hangs. –  Marty Sep 21 '12 at 16:21
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.