Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am using Kubuntu 12.04,currently.Recently ,I updated my system with update manager and downloaded USC from muon software center which was pre-installed in this system. I could download a lot of softwares such as: -firefox -XBMC media center -VLC media player But when I tried to get some more softwares using USC, after rebooting there began the problem . It does not begin either downloading or instaling the program. When I tried to download the same program using muon software center it showed the following:

                   Unable to obtain the package at this time  

Another application seems to be using the package system at this time. You must close all other package managers before you will be able to install or remove any packages.

I am quite sure that have closed USC . I tried to remove USC, assuming that it caused the problem using muon software center but the result was same.Now I cannot add or remove any programs into my system & I don't know what to do . Please help me as soon as possible.

share|improve this question
1  
are any other package manager opened ? –  raaz Sep 21 '12 at 10:02
add comment

3 Answers

up vote 0 down vote accepted

open the dash and type system monitoring then from process tab search for

software center


then right click and press stop process

If you didn't find software center in process tab search for apt-get or dpkg

share|improve this answer
    
you could also use this solution –  user91632 Sep 21 '12 at 11:22
    
no , there is no results for software center in process tab of system monitor –  Suhail cholassery Sep 21 '12 at 12:14
    
try seraching for apt-get or dpkg –  user61928 Sep 21 '12 at 12:15
    
yes, the only processes that i found on searching so was –  Suhail cholassery Sep 25 '12 at 4:49
    
please upvote and accept as answer if you solve your problem –  user61928 Sep 25 '12 at 5:01
add comment

try to see if any apt-* program is still running in the background by using :

ps ax | grep apt

Then kill the process by its pid:

sudo kill -9 [pid]
share|improve this answer
    
no that isn't working.it shows as follows in terminal when i tried this: ERROR: garbage process ID "[pid]". Usage: kill pid ... Send SIGTERM to every process listed. kill signal pid ... Send a signal to every process listed. kill -s signal pid ... Send a signal to every process listed. kill -l List all signal names. kill -L List all signal names in a nice table. kill -l signal Convert between signal numbers and names. –  Suhail cholassery Sep 21 '12 at 11:10
1  
you should put the real process id (number) not the [pid] word –  user91632 Sep 21 '12 at 11:19
    
when you issue ps ax | grep apt you get a list of process using the apt command and then you can take process ids from the first column of each line –  user91632 Sep 21 '12 at 11:22
    
yes ,i also tried using the process id ( like 2546 , 2546 )but its still the same –  Suhail cholassery Sep 21 '12 at 12:25
    
reboot your machine –  user91632 Sep 21 '12 at 15:25
show 1 more comment

try to make sudo apt-get update from terminal then try it again if the above solution doesn't work

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.