Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I somehow lost the "global menu bar integration" firefox addon. Probably uninstalled it accidentally.

I have tried dpkg-reconfigure and also apt-get remove firefox-globalmenu && apt-get install firefox-globalmenu. But neither worked.

How do I get the add-on into Firefox addon?

I couldn't find an xpi file either, to point firefox manually to it for installation.

Edit: Found a fix on my own, see my comment to the answer that was mots helpful :) Thanks everyone for looking into this.

share|improve this question
1  
try sudo apt-get purge firefox-globalmenu && sudo apt-get install firefox-globalmenu. –  green7 Sep 21 '12 at 9:08
    
Ah! Purged now. I have the PPA installed to use firefox-aurora (the next-next version of firefox) instead of the normal firefox. This means that there is no global-menu package in my list anymore :/ I could install firefox-globalmenu with the PPA disabled but APT complains that it wants firefox 15, not 17. Any chance to force-ignore this dependency check? –  freddyb Sep 21 '12 at 9:45
    
added an answer. tell me if it works. –  green7 Sep 21 '12 at 11:56
    
This issue occurred once more quite recently. Disabling the addon and restarting firefox then re-enabling and restarting again solved it for me here! –  freddyb Oct 5 '12 at 13:00

4 Answers 4

up vote 1 down vote accepted

Download the firefox-globalmenu here: http://security.ubuntu.com/ubuntu/pool/main/f/firefox/firefox-globalmenu_15.0.1+build1-0ubuntu0.11.04.1_amd64.deb

Install it by running:

sudo dpkg -i package.deb

Replace package.deb with the appropriate name.

share|improve this answer
    
firefox-globalmenu depends on firefox (= 15.0.1+build1-0ubuntu0.11.04.1); however: Version of firefox on system is 17.0~a2~hg20120920r106901-0ubuntu1~umd1~precise. Essentially, what I was asking for is a way to override this warning. –  freddyb Sep 21 '12 at 13:17
    
try sudo apt-get install --force-yes firefox-globalmenu. If that doesn't work try sudo apt-get install --ignore-missing firefox-globalmenu. –  green7 Sep 21 '12 at 15:23
    
That helped installing it, but I fixed it differently. I diabled the PPA and had to remove firefox completely; then installed firefox 15 which brought the globalmenu back. Then I upgraded to aurora (re-enabling the PPA). –  freddyb Sep 22 '12 at 9:19

Navigate to about:config, search for 'unity', and toggle from true to false

share|improve this answer

remove the new beta firefox :

sudo apt-get remove firefox

update your repository:

sudo apt-get update

then install latest stable firefox:

sudo apt-get install firefox sudo apt-get install firefox-globalmenu

share|improve this answer
    
It's not a problem with aurora, the ppa works fine and brings its own firefox-globalmenu –  freddyb Sep 22 '12 at 9:19

As you are using Firefox Aurora ( which is an unstable release) , sometimes you might get an update without the globalmenu package. The only thing you can do is to either wait for the new update from Ubuntu Mozilla Daily Build Team or remove the aurora ppa and install the stable release.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.