Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just installed 12.04 on an HP8510W. Everything works fine except for one weird behavior which I have noticed. When ever there is no audio playing, the audio mute indicator on the laptop is on. As soon as I start playing a you tube video the mute indicator turns off and I get sound.

Here is my pulse audio output which says that the sink is suspended because it is idle:

Welcome to PulseAudio! Use "help" for usage information.
list-sinks
1 sink(s) available.
index: 0
    name: <alsa_output.pci-0000_00_1b.0.analog-stereo>
    driver: <module-alsa-card.c>
    flags: HARDWARE HW_MUTE_CTRL HW_VOLUME_CTRL DECIBEL_VOLUME LATENCY DYNAMIC_LATENCY
    state: SUSPENDED
    suspend cause: IDLE 

I tried running alsamixer, but I don't see the auto-mute option.

share|improve this question
add comment

1 Answer

To stop pulseaudio from suspending a sink when idle we may comment out (by adding #) the following line in our default.pa (located in /etc/pulse/, or in ~/.pulse) to look like follows:

 # load-module module-suspend-on-idle

Restart the pulseaudio server to take effect (by running pulseaudio -k in a terminal)

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.