Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have installed a lot of fonts before, but this time things are really different. I have downloaded some True Type Font (ttf) fonts. Then paste them in the directory

usr/share/fonts

after that I've restarted LibreOffice writer but don't find them in the font list. No better result with PC rebooting.

Then again paste them in the directory

usr/share/fonts/truetype

and again restarted LibreOffice writer, but still they aren't on the font list.

I've tried in another way. Opened the fonts with font viewer and click on the "install" but the result is same. No improvement at all.

Latest

I've just found that those specific fonts are installed on my system, they present on gedit font list,but not in the LibreOffice font list. So, may be the problem is with LibreOffice.

Very surprising and irritating issue indeed.

share|improve this question
    
Thanks, This worked out just fine. Just had to restart my computer after these instructions and then the fonts were in the scrollbar on libreoffice Cheers, Guus van den Berg –  user142524 Mar 22 '13 at 12:49

3 Answers 3

I believe you should open /usr/share/fonts/truetype, then create a new folder in there, then place your fonts in that folder, and then run this in the terminal:

$ sudo fc-cache -f -v

After this is done, it is best to log out and back in to your account.

Solution source: Ubuntu Wiki - Fonts: #Manual.

On that page, you can also find explained other useful methods for installing fonts in Ubuntu both manually and automatically.

share|improve this answer
    
Thanks for your reply. I've follow the steps but no positive result. –  tuxtu Sep 21 '12 at 12:17
    
Then you might want to try other methods mentioned on Ubuntu Wiki page. Also, do you not see new fonts only in LibreOffice or they don't show in any of the programmes? –  Томица Кораћ Sep 21 '12 at 12:38
    
You are correct. My font is installed I found those fonts on gedit,but they are absent in LibreOffice. So,may be this is a problem with LibreOffice. Thanks for your help, but how can I solve my current problem :( –  tuxtu Sep 21 '12 at 16:44
    
Unfortunately, I have never worked with LibreOffice, so I can't know without looking into it. For now I can advise you to check if the new fonts are at least available in in any of the LibreOffice suite programmes (like Write, Calc, Base etc.) or they're missing in all of them. If they're missing, you can try to reinstall LibreOffice. Just make sure to delete all the files that could affect LibreOffice settings. And of course, make a backup of everything you might need. –  Томица Кораћ Sep 22 '12 at 13:26
    
Recently I've found a new improvement. I've pasted the fonts in the .fonts folder in my home folder. After that I'm able to use those fonts in LibreOffice.But I don't understand why the method (you mentioned) wasn't successful. –  tuxtu Sep 23 '12 at 4:46
up vote 5 down vote accepted

I've found a solution for this problem. To do that you have to paste the fonts in the directory

   home/.fonts

It's important to mention here that, normally, you can't see the folders which started with a dot(.)(in ubuntu folders started with . are hidden folders). To see these folders press ctrl+h or click view > show hidden files.

Now if you don't have a folder named .fonts, then create one and paste your desired fonts in that folder.

This solution worked for me hope it can help others.

share|improve this answer
    
If you want to have a visible fonts-folder, add a symlink: ln -s .fonts fonts. Then you can paste fonts into that folder. –  SPRBRN Nov 19 '12 at 10:59

LibreOffice (at least 3.6 and 4.1) require the font's .pfb and .afm files to be present. If you don't have both, LibreOffice will not display the font in the font list. This is different to most other programs that are happy with only the .pfb. This requirement is verified by one of the LibreOffice developers in this LibreOffice Bugzilla bug comment.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.