Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm running the latest version of Ubuntu, and I have a Dell Sp2009wfd monitor with built in microphone and webcam. I've gotten the microphone working on mumble and on sound recorder, and I've gotten the webcam to work on Cheese...but it WON'T work through the flash player//website webcam things. I -have- the flash plugin, and I have drivers installed for my video card. Could anyone help me figure this out? It's really frustrating.

Thank you...!

share|improve this question
add comment

5 Answers 5

If your problem is something like the image below, follow the steps given.

This problem usually occurs in Firefox where you can't click on Allow.

enter image description here

enter image description here

  • Select the website to which you want to allow webcam access and select Always Allow.

enter image description here

  • Refresh the website again and you're done!
share|improve this answer
add comment

Try installing Chrome browser, not Chromium and see how you go. I have the same cam and it works out of the box with Chrome and with PulseAudio if you have sound issues.

share|improve this answer
add comment

Before you're able to use your microphone and camera inputs in your browser, you need to explicitly allow it in the Flash Settings window. That, however, can turn out to be easier said than done, but I'll explain a workaround.

Open your browser, go to any page with Flash content. Right click on Flash content and select Settings from the menu. A small dialogue window will open, with tabs at the bottom. Click on the middle tab (third from left) which depicts a folder and a green arrow. Now, click on the 'Allow' option, with the green check icon. Finally, click Close button.

This won't work, if, after selecting 'Settings' from the drop-down menu Flash refuses to accept mouse clicks. Basically, you can't do anything else in that dialogue but stare at it. If that happens to you, here's what you can do. Log out from your account, then log in to Unity 2D. Do the same process under Unity 2D, then log out and log back in to Unity 3D.

share|improve this answer
add comment

I used my webcam in the browser, when I was taking a coursera signature track course. When you do that you always have to take a picture of you with your webcam before you submit any work you did.

On my laptop I am running Ubuntu 12.10. I tried different browsers (Firefox, Chromium, Chrome), but the coursera website was not able to address the webcam. I tried to change the flash settings in the Adobe Falsh Player Settings directly in the browser. But this did not work. It looks like you can change it, but the changes are never saved.

But, then I found this post by green7 and it really saved my day. I clicked on the link below.

http://www.macromedia.com/support/documentation/en/flashplayer/help/settings_manager06.html

This link brings you directly to a website from Adobe that displays a "Privacy Settings panel" of your browser. Here I was able to select the coursera website (coursera.org), select the option always allow and click save.

Now the coursera website was able to address my webcam and I was able to take a picture from myself and submit my work.

I hope this helps other people as well. Good luck!

share|improve this answer
1  
Welcome to Ask Ubuntu! Whilst this may theoretically answer the question, it would be preferable to also include the essential parts of the link here. –  Thomas W. Apr 22 '13 at 19:29
add comment

Step 1: Type in search box (Google Chrome only): chrome://plugins/

Step 2: Adobe Flash Player - must be: [X] Aways allowed

Step 3: See the magic :)

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.