Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Does anyone know how to start RhythmBox in quiet mode?

share|improve this question
add comment

6 Answers 6

There is a plugin for this...

disclaimer - I'm the author for this plugin

Called rhythmbox_hide, this is a little applet that either starts rhythmbox hidden or minimized.

By default, when the plugin is enabled through the menu option Edit - Plugins, rhythmbox starts hidden on startup, but through the plugin preferences you can uncheck this option and rhythmbox will then start minimized.

enter image description here

This plugin is particularly useful in combination with another plugin called remember-the-rhythm.

When used with this plugin you can start rhythmbox via the startup applications option for your Desktop Environment and on login, your last track that was playing will be immediately start playing.

how to install

sudo apt-get install git
git clone https://github.com/fossfreedom/rhythmbox_hide
cd rhythmbox_hide
./install.sh

You will be prompted for your password which installs the dconf schema key used to remember your preferences option.

Alternatively, if you prefer a package installation method:

sudo add-apt-repository ppa:fossfreedom/rhythmbox-plugins
sudo apt-get update
sudo apt-get install rhythmbox-plugin-hide

Linked Question

share|improve this answer
    
Works great, also seems to work great on Fedora 19 (booing noises in background) - slight delay inwhich the Rhythmbox window appears and then disappears, but that's fine. Use with gnome-do, this extension, and media keys to run rhythmbox in background. –  Wilf Apr 2 at 21:38
add comment

Simply make the main window disappear by clicking on the x button; rhythmbox should still sit in the panel and you can control it and quit from there.
Now it should remember this and the next time you open rhythmbox the main window will not show.

How to force it to never show the main window when opening I have no clue.

The gconf value of /apps/rhythmbox/state/window_maximized is not what you are asking for; it only shows if the main window is maximised or not.

Although rhythmbox-client --hide should do the job it's not working for me.

I tested this with version 0.12.8-0ubuntu7 on Lucid.

share|improve this answer
add comment

rhythmbox-client --hide in place of rhythmbox %U in the launcher

share|improve this answer
    
This doesn't work for me. –  8128 Jan 29 '11 at 20:08
    
not working as well .. also this is not a practical case to replace %U here –  warl0ck Oct 16 '11 at 13:02
1  
There's no a --hide option in rhythmbox or in rhythmbox-client. –  dadexix86 Nov 5 '12 at 13:36
add comment

This doesn't look very pretty (something I am a stickler for), but if all else fails you can just close the window as soon as it opens using devilspie. This link explains how to start applications minimized, but in your case you replace the provided example's "Terminal" with "Rhythmbox" and "minimize" with "close". Thus, your devilspie rule should look like this

    andrey@spider ~ $ cat .devilspie/rhytmbox.ds (This isn't actually part of the file, I just put it there to show you where it is)
    (if
       (is (application_name) "Rhythmbox")
       (begin
          (close)
       )
    )

If you have problems with rhythmbox not opening after being closed, try changing the notification icon preferences. The variable in question is in: rhythmbox menu > edit > plugins > status icon > configure > status icon: change it to "owns the main window"

Official devlispie documentation is here

share|improve this answer
    
This is only for metacity. Any news for Unity and compiz? –  dadexix86 Nov 5 '12 at 13:41
add comment

I think you can do this with gconf-editor.

/apps/rhythmbox/state/window_maximized <- make sure the box is unchecked

share|improve this answer
add comment

Just click to volume icon in the top menu of your desktop, and then click to play icon.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.