Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I upgraded to Precise Pangolin 12.04 and my Samba file sharing FROM windows has stopped. Windows Vista has worked o.k. in the past. Now Ubuntu can see files on a Windows Vista computer and an XP machine on my LAN, but not the other way around. Windows can ping the Ubuntu machine, no problem, either under its ip address or network alias. This is very irritating. Does anyone know how to fix this?

share|improve this question
Which version did you upgrade from? – Aaron Sep 20 '12 at 16:28

issue the following command from the terminal sudo apt-get install system-config-samba

After that, go to Dash and open Samba.

Next, click the Add button (plus) , then browse to the folder to wish to share and open it. Then enable Write and Read permission on the folder.

Next, select the ‘Access’ tab and enable the users you wish to have access to the shares and click OK.

After that, run the commands below for each user account to add it to Samba database. This will allow you to create new password for Samba. It’s always good to use the same password as your Ubuntu account.

sudo smbpasswd -a <username>

That’s it!

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.