Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Somehow after upgrading to 12.04, my virtual machines always boot with an attempt to boot from the network first. See this:

virt-manager screenshot

while I don't have any PXE configuration set:

PXE boot configuration

I've tried:

  • to disable SPICE, by changing the emulator to /usr/bin/kvm from /usr/bin/kvm-spice by editing the XML.
  • Ctrl+B to configure the iPXE, but it doesn't let disable this as a boot option.
  • setting another type of NIC - not an option, I need virtio for performance reasons. However, e1000e doesn't work either.
  • removing the NIC: works. However, I need network.
  • Googling around. Hard. Lots of result is about failing configured PXE boots.

Not a big issue, but it increases boot times by 50-100% here (booting from SSD), so it's relatively long and annoys me.

How can I disable this and boot from virtual hard disk directly?

share|improve this question

5 Answers 5

From your pictures, I can see that most likely it has to do with the VM BIOS. The VM configuration must not overwrite SeaBIOS' settings, something which must be causing the VM to boot from PXE first.

For a first possible solution, try to see if you can enter the Virtual Machine's BIOS and edit the options prevalent there.

NOTE: Will continue to update the answer while my research unveils more possible solutions or causes.

[EDIT #1]: You can find information on how to set up the boot order in SeaBIOS here. That should solve the problem.

share|improve this answer
    
How can I enter the VM's BIOS? Wikipedia about SeaBIOS tells me I should try F12 at boot time, but that only triggers skipping the iPXE attempt once. –  gertvdijk Sep 20 '12 at 14:00
    
@gertvdijk I am currently looking into it. I will get back to you as soon as I find out. –  NlightNFotis Sep 20 '12 at 14:01
    
@gertvdijk This seems somehow related: seabios.org/pipermail/seabios/2012-March/003526.html –  NlightNFotis Sep 20 '12 at 14:02
    
Thanks, learned new stuff today. However, this seems to apply system-wide and about building a new CBFS (core boot filesystem). As far as I can see, it also disables PXE booting altogether. I don't like this approach and I think it should be possible to prevent iPXE booting attempts runtime as is possible in virt-manager GUI. –  gertvdijk Sep 20 '12 at 15:11
    
@gertvdijk How do you know it disables it? All I can see is to set up the boot order, meaning something gets booted prior to something else. –  NlightNFotis Sep 20 '12 at 15:15

My experiments on the same issue gave me some hints:

The package kvm-ipxe installs several PXE option ROMs into /usr/share/qemu/:

pxe-e1000.rom
pxe-ne2k_isa.rom
pxe-pcnet32.rom
pxe-rtl8139.rom
pxe-virtio.rom

Somehow these are automatically found and used by seabios when booting with one of these NICs. When I do a chmod a= pxe*.rom on these files and start the virtual machine I get the "error" message

kvm: pci_add_option_rom: failed to find romfile "pxe-rtl8139.rom"

but it boots cleanly and without PXE.

share|improve this answer
    
Thanks. That gives me a bit of a workaround: using virtio for general networking devices and e1000e for VMs that need PXE. However, I still think it's a bug. Somehow Libvirt does not successfully pass the right boot parameters to SeaBIOS. –  gertvdijk Sep 23 '12 at 16:09
    
@A.H. Thanks, works for me! –  mcandre Oct 10 '12 at 17:30
up vote 3 down vote accepted

Short answer

Upgrade to libvirt 0.9.10+ (available in Quantal) and add the <rom bar='off'/> option to the interface configuration of the machine's XML definition.

Long answer

Now that I'm actually using the iPXE boot option I see that the delay occurring in the SeaBIOS screen is not an actual boot attempt. It's just loading the Virtio network option ROM and that takes a few annoying seconds, i.e. it's not yet doing an iPXE boot attempt. This lead me to read the libvirt documentation again, and I made an interesting discovery.

As far as I could find, since libvirt 0.9.7 the behaviour has changed to load interface's option ROMs by default. Ubuntu 11.10 shipped with 0.9.2, Ubuntu 12.04 comes with 0.9.8. This definitely makes sense as to why I see this happening since the upgrade to 12.04.

Moreover, this has become configurable in libvirt version 0.9.10 with the <rom bar='off'/> option in the XML! (see here) However, that version of libvirt is not available in Ubuntu 12.04 and I'll have to upgrade to 12.10 or backport it. This makes Ubuntu 12.04 fall between two stools.

Other workarounds are removing the option ROM files as pointed out by @A.H.' and changing the SeaBIOS 'filesystem' as pointed out by @NlightNFotis. However, both ways will basically disable iPXE completely and it's not configurable (if sticking to virtio network devices only). As I have a mixed setup of iPXE machines and non-PXE machines, I really need this to be configurable.

share|improve this answer

I was able to get around this in Ubuntu 12.04 by passing the following options to qemu-kvm on the command-line (setting the romfile to blank is the trick):

-netdev user,id=hostnet0 -device virtio-net-pci,romfile=,netdev=hostnet0
share|improve this answer
    
Cool, but can I specify this in my Libvirt XML machine definition? –  gertvdijk May 31 '13 at 7:00

I was able to prevent this using "-net none":

# qemu-system-i386 -net none
share|improve this answer
    
But then you don't have any networking at all! I consider this not really an answer. –  gertvdijk Nov 11 '13 at 1:56
    
Sorry, I missed the fact that OP still needed networking. In my case running with no network was acceptable. –  Catalin Patulea Nov 11 '13 at 5:23

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.