Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm using a Logitech K750(keyboard) and M705(mouse) using the same (one!) unifying USB connector. I paired them with my mac, but use them on my desktop with Ubuntu 12.10. Works nice. Just a few adjustments I'd like to do.

This mouse allows to disable the "steps" of the scroll wheel easily, which enables me on the mac to scroll stepless like using a touchpad. I'm not talking about smooth scrolling but stepless scrolling! This does somehow not work on Ubuntu. Is there no possibility to do this? This mouse also supports horizontal scrolling (not stepless). Is there a way to adjust these features? Maybe in xorg.conf? Maybe someone has a mouse xorg.conf-section I can experiment with?

xev | grep button tells me there's no difference between using the wheel with or without steps (Button 4 and 5). So the thing should just be a question of software interpretation. At least it's a question of making steps smaller (1 pixel?) and enable acceleration, I think.

share|improve this question
    
Sounds like a driver issue, smooth scrolling for Linux is new after all. Have you tested this mouse with 12.10? –  NoBugs Oct 27 '12 at 16:28
1  
I'd be interested in seeing a screencast of the expected behavior, if you don't mind. I have the same setup and use "hyper-fast" scrolling all the time. I haven't noticed any problems, but I also haven't seen how other operating systems respond to it. –  ændrük Nov 8 '12 at 21:11
2  
For those unfamiliar with the mouse: A toggle switch adjacent to the scroll wheel physically decouples the wheel's ratcheting mechanism, allowing the wheel to spin freely. The wheel is weighted, so it can spin on its own like a flyweel for several seconds, generating hundreds of otherwise-normal clicks per second. –  ændrük Nov 8 '12 at 21:35
2  
I think this is a nice example. I have the G9 but I didn't miss the stepless scrolling, then I saw your question and now I do :( –  Gerhard Burger Jan 16 '13 at 20:48
1  
With natural scrolling you mean the direction you slide with your fingers with a touchpad I suppose. Well, it's comparable with the smooth stepless scrolling of some touchpads (especially on MACs). The video in the comment before yours shows it well. Stepless scrolling allows you to control scrolling accurate to one pixel if needed in an intuitive way and is not confusing while reading. You need a mouse with a little extra button or a touchpad to use this. –  verpfeilt Jan 28 '13 at 11:36

2 Answers 2

This is currently the best solution I found, although I think at this time, it's smooth scrolling feature is not yet useable. In future, native, driver-based solutions have to be made to support mice and touchpads which support smooth scrolling. Especially on a desktop system like ubuntu.

Solaar

There is an application called Solaar which offers many possibilities to unifying-devices from Logitech, like battery status, pairing options (awesome!) and smooth scrolling. Unfortunately smooth scrolling does not work that great, it does not scroll as smooth as on OSX, and it does only scroll the last active window, not the mouse-overed window (tested on 13.04). But it's in every way a useful application and it's smooth scrolling feature is something I hope get's improved with future updates.

Homepage: http://pwr.github.io/Solaar/

Installation

Open a Terminal via the unity dash or CTRL+ALT+T and paste in the following lines:

sudo add-apt-repository ppa:daniel.pavel/solaar
sudo apt-get update
sudo apt-get install solaar

Usage

  • Start Solaar via the unity dash for example.
  • If you see a popup recommending to replug the unifying-receiver, do it.
  • There should occur a tray icon looking like a battery. If you open it and click on a device, you'll see information about your devices.
  • On the right of the entry for your mouse should be a settings icon. Click it and a "smooth scrolling" option should appear.
  • Try it, it's easy to disable again in case it does not work for you.
  • If you experience problems like the horizontal scrolling does not work, try replugging the receiver again.
share|improve this answer

In /etc/X11/xorg.conf in the mouse section:

Option         "Buttons" "1 2 3 4 5 6 7 8 9"
Option         "ZAxisMapping" "4 5"

in /etc/X11/imwheel/startup.conf:

IMWHEEL_START=1
IMWHEEL_PARAMS='-b "0 0 0 0 6 7"'
share|improve this answer
    
In my xorg.conf is no mouse section. Also, /etc/X11/imwheel/ does not exist. I'm on Ubuntu 12.10 (I'll edit this info in the question above now). –  verpfeilt Feb 20 '13 at 15:54
2  
you can add mouse section manually in xorg.conf. Is imwheel package installed in your system? –  jasmines Feb 20 '13 at 16:03
    
I just installed imwheel and configured startup.conf. But I'm not sure on how to create a mouse section yet. (Seems like it does not work without it). Do I see it right that the "mouse" section is supposed to be a "InputDevice" section? (x.org/archive/X11R6.8.2/doc/mouse5.html) Also, it seems like that the horizontal scrolling does not work anymore since I installed and configured imwheel. These Keys have now the same function as the back/forward buttons. (they also have the same numbers) –  verpfeilt Feb 20 '13 at 16:22
    
Also, I don't see how this is going to give me stepless scrolling. As far as I get this, imwheel just maps the buttons to a function. I solved the horizontal scrolling by changing the map to the standard one for now, which is for my mouse: IMWHEEL_PARAMS='-b "4 5 6 7 8 9 10"' (10 is a third thump button). –  verpfeilt Feb 20 '13 at 16:46
    
@jasmines Please explain why this works, what it does, and whether it is specific to the Logitech M705 or solves the analogous question for other mice. Thanks! –  user29020 Jul 6 at 23:46

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.