Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Possible Duplicate:
Add custom command in the open with dialog?

I would like to open e.g. webm files using mplayer, but it is not available in the "Open With" dialogue and (quite frustratingly) the dialogue no longer allows selection of the program to use from the file system.

Is there a conf file I can edit directly to get this done?

share|improve this question

marked as duplicate by izx, Anwar Shah, jokerdino, Mitch, Ringtail Sep 20 '12 at 13:53

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
Hi Tomislav.... which "buntu" are you running? –  Malee Sep 20 '12 at 13:00
    
I'm using 11.10 and Unity. –  Tomislav Nakic-Alfirevic Sep 20 '12 at 13:19
    
@izx Indeed, this is an exact duplicate. –  Tomislav Nakic-Alfirevic Sep 20 '12 at 13:21
    
Try Nautilus actions. –  Mitch Sep 20 '12 at 13:23

2 Answers 2

If you'r using 11.10 i found this for an application called nedit.

Quoting mc4man

fairly easy - nedit's .desktop is missing something to allow it to be shown in the r. click context menu

Code:
gksudo gedit /usr/share/applications/nedit.desktop

find the Exec= line & add a %f to end, leave a space between nedit & %f - ignore the untitled document 1 that also opens - close it without saving, do save the nedit.desktop

Code:
[Desktop Entry]
Version=1.0
Name=NEdit
Exec=nedit %f
Icon=Nedit
Terminal=false
Type=Application
Categories=Motif;Utility;TextTools;
GenericName=Text editor
GenericName[en]=Text editor
GenericName[nl]=Tekst verwerker

Then you'll find it by right clicking on your file > open with > other applications After that it will be shown directly in the r. click menu

If you wish to set nedit as default for all text files then use the right click > Properties > open with instead

If, in other hand, you're using 12.04 you can do it like this:

If you want to delete applications from the openwith list you have to edit the following file from command line

/usr/share/applications/mimeinfo.cache

If you added item by yourself, or you want to add new item you need to edit the following file from command line

~/.local/share/applications/mimeinfo.cache

default actions you need to edit the following file from command line

~/.local/share/applications/defaults.list

share|improve this answer
    
I have nor the the mimeinfo.cache nor the defaults.list: the only file I have in that folder is mimeapps.list...I would say we're probably using different versions of Ubuntu. –  Tomislav Nakic-Alfirevic Sep 20 '12 at 13:24

There will be one more option like open with other application , select that . a window will open with browse option and navigate to usr and then to bin folder and there you can select the application you want .

I am using KDE and i will post those images and i hope they will help you to understand . enter image description here enter image description here enter image description here

share|improve this answer
1  
While I am grateful for the advice, I'm using 11.10 and Unity, so I don't think these instructions would help me. –  Tomislav Nakic-Alfirevic Sep 20 '12 at 13:23
    
My intension behind this is to make you understand what you have to do . :D –  AgentCool Sep 20 '12 at 14:37

Not the answer you're looking for? Browse other questions tagged or ask your own question.