Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm new to ubuntu and I'm afraid I've done something really stupid.

After booting, When prompted to enter a password to unlock my login keyring, I tried to enter in my password, but it won't let me.

I can move my cursor but everything else is frozen.

I tried to access the terminal by using Ctrl + Alt + F2, I entered my login and password from there and it worked, I just don't know what to do afterwards.

Don't know what other information I can provide other than the fact that I am using Ubuntu 10.04

share|improve this question

closed as too localized by Luis Alvarado Mar 14 '13 at 16:36

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

Switch to X (the graphical interface that is frozen) usually by typing Alt+7 and then type Alt+SysRq+k .

This will kill X and it will restart. This is kind of a "nasty" solution but without additional details and debugging is the best I can offer.

-- or --

logged in on a virtual console (or remotely) type sudo service gdm restart

share|improve this answer
Thank you so much!!!!!!! – Maddie Aug 11 '10 at 2:34
YW, glad it helped! – Li Lo Aug 11 '10 at 2:35

Have you tried just pressing Escape?

Seems silly but I used to have something like this happen to me. Gnome would load up and a keyring unlock prompt would show. If I entered within a minute, fine. If I took too long the system would focus on something else (that I couldn't see) and the mouse or keyboard wouldn't let me move back to unlock it.

One day I mashed the keyboard in frustration, hit Escape by accident and the keyring box reloaded, allowing me to type its password.

I've since found that the reason the login pops up is because of network-manager. I've changed all my connections so that "Available to all users" is checked and now I don't get any annoying popups. I'm told removing the password from the keyring is another solution but it's less secure.

share|improve this answer