Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

My Bugzilla4 works perfectly.

I am trying to enhance our security, so I have created a special user on our domain called: srv.ldap - It should only have LDAP access, and be used for this reason only.

I tried to replace the user on the LDAP settings in the parameters window, but no matter what I do, I keep getting an error.

I even copy/pasted the domain administrator, and only changed it's name and password: and I get the LDAP connection error.

enter image description here

  • I know that my LDAPBINDDN is correct
  • I can connect with my administrator to the LDAP from the bugzilla
  • I can connect with an LDAP browser with the srvldap user and the password I have
  • I can't connect with ANY other account than administrator (from bugzilla)

Any ideas?

share|improve this question
    
This link might help you. –  devav2 Sep 20 '12 at 11:57
    
thanks, not helping. I am ABLE to work with my domain administrator account. I can't with other accounts. Read question –  Saariko Sep 20 '12 at 12:03

1 Answer 1

Your question is not entierly clear

If I understand you correctly. You don not want to use an Admin account for the ldap bind to your ldap server. But using another user fails to bind.

You don't specify what LDAP server you are using. I presume its MS Active Directory becasue of the term "Domain" and "Domain Administrator".

In Active directory you either have to allow anonymous ldap queries or make sure that the user account you specified has read permission on the part of THE AD where you want to read out information.

You could verify the correctness of your settings outside outside of bugzilla using ldapsearch from the command line on a Linux machine

anonymous:

 ldapsearch -LLL -H ldap://yourdomain.com:389 -b 'dc=int,dc=yourcompanmyname,dc=com' -D 'DOMAINNAME'  '(sAMAccountName=usernametosearchfor)'

with credentials:

 ldapsearch -LLL -H ldap://yourdomain.com:389 -b 'dc=int,dc=yourcompanmyname,dc=com' -D 'DOMAINNAME\binduser' -W  '(sAMAccountName=usernametosearchfor)'
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.