Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I use Band-in-a-box ("BIAB") to create backing tracks to practice my guitar-playing, and keep the source files (filetype .MGU) created by BIAB in the same folder as the MP3 files derived from them. Because I share this folder with colleagues via Dropbox, I'm not in a position to move the .MGU files elsewhere.

Every time I start Rhythmbox ("RB") it checks my music folders, and reports "Import Errors" on all the .MGU files.

RB apparently ignores a number of unplayable filetypes in music folders - is there a way of adding .MGU to this group?

I know I can just ignore the Import Errors, but one of these days there will be an error I would have wanted to know about.

share|improve this question
add comment

1 Answer

Rhythmbox uses gstreamer to open files. So, if there is a plugin that supports this exotic file type, the problem might be solvable.

In 12.04,

sudo apt-get install libgstreamer-plugins-bad0.10-0

will install, among others, a plugin called WildMidi which allows gstreamer to play midi-files (mgu-files are a type of midi files). However, it's not guaranteed that WildMidi will be able to play those mgu-files. If they don't have to be mgu-files you might try to convert them to a midi-format that you and your friends can still use and which can also be read by rhythmbox.

I've found no option in Rhythmbox that could do what you're looking for. Maybe a different player does the job?

Otherwise, you might as well copy those files to a new folder and share this one with your friends too (I know this is not what you were looking for but mgu is an exotic file type and rhythmbox has no native support for file blacklisting).

share|improve this answer
    
Thanks for your prompt and informative response. I already have the plugins installed, so that trick won't work. In any case, I don't want to "play" the .MGU files, as I've got rendered versions of them as .MP3s already, so I'll just have to put up with the Import Errors until someone puts an ignore-these-files feature into Rhythmbox. –  user69245 Sep 20 '12 at 13:23
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.