Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Whether I run Ubuntu as a live-USB or install it, I always have two trash bins on the Unity Launcher. Both work, and both open the same location.
This seems a bit redundant; what could be done about it?

Update: Turning auto-hide on made it obvious that I have multiple Launchers showing. With auto-hide off, they simply overlap, making it look like there's a double trash icon, but with auto-hide enabled, I can display one Launcher (and therefore one trash icon) at a time. Still, two are running simultaneously.

Second update: This problem appears to be caused by the way Ubuntu handles multiple displays on my Asus UX32VD Ultrabook. Somehow, the laptop display cannot be used while my external display is connected. It is shown in the Displays list, but remains black no matter how I configure it.
The external display runs at 1920x1200, the laptop monitor should run at 1920x1080. It therefore becomes obvious that the Launcher that's supposed to run on the laptop display, is actually displayed on the external monitor.
Using nomodeset as a kernel parameter as indicated here makes the laptop display inaccessible altogether, detecting the external monitor as the laptop display and making resolutions other than 1920x1200 inaccessible. That is not an option.
Without nomodeset, the external monitor works as it should, but the laptop monitor stays black. When I disable the laptop monitor, the external display goes black, too.

Screenshot

share|improve this question
    
Is this issue only in your user account or across the system? –  green7 Sep 20 '12 at 8:26
    
@green7: Since it already occurred on the live-USB, I assumed it would occur across the system. I just checked on the guest account, and yes: two Launchers. –  oKtosiTe Sep 20 '12 at 8:37

1 Answer 1

  • First check that the Ubuntu ISO is correct by checking the md5sum or sha1sum.

    To check, run the following command on the terminal:

    md5sum /path/to/ubuntu/image.iso

          And make sure they match to the ones give on the release page.

enter image description here

  • If they don't match, download the image again.

  • However, if they do match, this would be a bug. Please report it on launchpad.net.


Update: As answered here, it can be a gpu problem. If you've nvidia card, make sure all the drivers are installed.

Then, run the following command from the terminal:

sudo nvidia-settings

You can now configure multiple displays and gpu settings.

share|improve this answer
    
It matched. Actually, I think I just stumbled on the root cause of the issue, will post as an answer shortly. –  oKtosiTe Sep 20 '12 at 8:42
    
Posted as a second update instead. –  oKtosiTe Sep 20 '12 at 9:15
    
never knew you had multiple displays :P –  green7 Sep 20 '12 at 11:51
    
updated the answer. –  green7 Sep 20 '12 at 11:59
    
Actually, I've read in several places that the NVidia card on this laptop is not supported properly yet with its Optimus switching. In the next few days I'll try Xubuntu and possibly other distros, but perhaps the only option I have is to wait this one out until driver support improves. –  oKtosiTe Sep 28 '12 at 10:02

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.