Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Most of the time, I don't need autocompletes for my hidden directories. In fact, that's the point of them being hidden! However, annoyingly, bash takes these directories into account when considering tab autocompletion.

This is particularly annoying when I have the following scenario: a .svn foler along with a single folder that I want to traverse into by simply pushing tab. (This typically comes up with deep Java packages...)

Is there any way to change the default behavior? Worst case scenario I have to type '.' before tab, which seems like a no brainer for my usability.

share|improve this question
add comment

1 Answer 1

up vote 7 down vote accepted

Just add this line to your ~/.bashrc (if you don't have one, create it):

bind 'set match-hidden-files off'

And bash-completion should behave the way you want.

There are also many other options you might want to tweak in bash-completion. To see a complete list, read the manual ;)

share|improve this answer
    
Great! Will accept after nine minutes, did not know that this was an option.. –  Kristopher Micinski Sep 20 '12 at 1:42
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.