Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I can't install the Photo Lens. After running these commands:

sudo add-apt-repository ppa:scopes-packagers/ppa
sudo apt-get update && sudo apt-get install unity-lens-photo unity-scope-shotwell unity-scope-flickr

I get this:

Package unity-lens-photo is not available, but is referred to by another package. This may mean that the package is missing, has been obsoleted, or is only available from another source

E: Package 'unity-lens-photo' has no installation candidate

Is there a fix for that? Thank you very much.

share|improve this question
    
Which version of ubuntu are you running? It sounds like it's not built for your version yet. –  Chris Wayne Sep 20 '12 at 15:54
    
Hi @Chris. I am using Ubuntu 12.04.1 LTS. I believe it should work anyways. –  Chuqui Sep 21 '12 at 3:11
add comment

4 Answers

unity-lens-photo separately download the DEB package to install later, and at the end: sudo add- apt-repository ppa: scopes-packagers/ppa sudo apt-get update && sudo apt- get install unity-lens-photo unity-scope- Shotwell unity-scope- flickr for me it works P.S. Some of the packages that are needed and there is no time, unfortunately, is not easy to separately download:)? I greet

share|improve this answer
add comment

In order to install Unity Photo Lens on Ubuntu 12.04, I had to install the deb package found here. That solved the Flickr problem but not the Shotwell functionality.

share|improve this answer
add comment

For some reason, unity-lens-photos is not available in the scopes-packagers PPA. However, you can download a .deb file containing unity-lens-photos from here. Double click on the downloaded file to install the lens.

You will still need to install the unity-scope-shotwell and unity-scope-flickr packages (from the PPA) in order to provide sources for the lens to search and log out and back in again in order to activate the lens.

share|improve this answer
add comment

After a brief look at https://launchpad.net/~scopes-packagers/+archive/ppa?field.series_filter=, it seems that there is no package named unity-lens-photo. It looks like unity-lens-photos, however is in the main archive for quantal (12.10) but not for precise (12.04).

If you really want it in 12.04, you could update your unity to the quantal version with this ppa (https://launchpad.net/~benkai/+archive/precise-unity-backport) although that could be a bit risky as it is still in beta.

share|improve this answer
    
Hi again. Thanks for your help. It sounds very reasonable. I have one more question... will I obligatorily have to update Unity to the Quantal version anyway someday or not? I'm planning to use 12.04 LTS for at least for 2 or 3 years. And the last thing. If I do what you say in order to see if that's the problem, can I safely go back to the actual Unity version? Thanks! –  Chuqui Sep 21 '12 at 11:59
    
A friend didn't have problems in 12.04. It's in spanish but look his output: lsb_release -a No LSB modules are available. Distributor ID: Ubuntu Description: Ubuntu 12.04.1 LTS Release: 12.04 Codename: precise linuxnoveles1@linuxnovelesVB:~$ sudo apt-get install unity-lens-photo unity-scope-flickr Leyendo lista de paquetes… Hecho Creando árbol de dependencias Leyendo la información de estado… Hecho unity-scope-flickr ya está en su versión más reciente. unity-lens-photo ya está en su versión más reciente. 0 actualizados, 0 se instalarán, 0 para eliminar y 26 no actualizados. –  Chuqui Sep 21 '12 at 13:07
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.