Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm running Ubuntu 10.04 in a Virtual Machine on a Windows 7 computer. If I press Ctrl-Alt-Delete when the Ubuntu VM is in focus, the Ubuntu system sees it and shuts down after 60 seconds. This does not happen if the Ubuntu VM is not in focus. I know I could just "be careful", but I'd like to avoid accidentally shutting down my Ubuntu system every time I lock my machine.

I found the following directions for disabling this behavior on Ubuntu:

To disable Ctrl+Alt+Del REBOOT edit #sudo nano /etc/init/control-alt-delete.conf comment out:

#start on control-alt-delete
#task
#exec shutdown -r now “Control-Alt-Delete pressed”

I tried that, but it's not working (even after rebooting the system). Considering how common this answer appeared to be, I'm a bit confused. Any other ways to disable this behavior? Thanks!

share|improve this question
    
Why do you lock Windows with Ctrl+Alt+Delete? You can do it with Win+L? (Win is that Windows logo on the keyboard) –  Dan Sep 19 '12 at 17:43
    
Too much time with old school IBM keyboards or modern Apple keyboards I guess. :) –  GrandAdmiral Sep 19 '12 at 18:29
add comment

2 Answers 2

up vote 2 down vote accepted

Not sure if this works the same in 10.04, but in 12.04 this is controlled by keyboard shortcuts, and you can easily disable it using GUI:

enter image description here

Is a similar dialog available in 10.04? (try in System > Preferences menu)

Also, as Ben pointed out, even if you prevent Ubuntu from Logging out / Rebooting / Shutting down etc, the simple fact of Ubuntu receiving the Ctrl+Alt+Del event from the VM software may prevent your host OS from acting upon it when Ubuntu has the focus.

That means you may fix the issue in Ubuntu side, but you would still need to make sure that this event is not captured by the client, even if it has the focus.

In VirtualBox, there's an "Auto-Capture Keyboard" option that controls this behaviour.

share|improve this answer
    
A similar dialog is available, but it does not allow you to disable the Log out Action. It appears the VMWare Player is the one that is allowing both the Ubuntu VM and the Windows machine to see the Ctrl-Alt-Del. I'd be okay if Windows didn't see the Ctrl-Alt-Del if the Ubuntu VM was in focus. I'd trade that problem for accidentally closing my Ubuntu VM when I lock the screen. –  GrandAdmiral Sep 19 '12 at 18:23
1  
@GrandAdmiral: have you tried clicking the shortcut row (to edit the current shortcut) and then pressing Backspace to disable the shortcut? If that does not work, you may change the Log out to something else (say, Ctrl+Alt+S) –  MestreLion Sep 19 '12 at 18:27
    
Hey, that worked! You know, I tried doing that before but for some reason it didn't seem to take until now. I'm a bit puzzled why the "GUI fix" worked when the command line version didn't, but as least it's solved. Thank you very much for your help. –  GrandAdmiral Sep 19 '12 at 18:34
    
The "command-line version" you mention have nothing to do with my approach, and it's not the command-line equivalent of it. There is an equivalent using gconftool, I could search for the exact parameters if you want to. –  MestreLion Sep 19 '12 at 18:55
add comment

There may be a chance that the VM software intercepts your pressing of Ctrl+Alt+DEL and sends a "reboot" signal to the virtualized machine.

You should have a look at the VM soft properties regarding the interception of Ctrl+Alt+Del, maybe.

If you're using VMWare, here is the trick : http://www.itworld.com/virtualization/242537/disable-ctrl-alt-del-vmware-virtual-machines

Hope this helps,

Ben

share|improve this answer
    
Unfortunately that didn't work, even though I found a similar suggestion in the VMware Player knowledge base when I was trying to find the path to the config.ini file. FYI for anyone looking, it's C:\ProgramData\VMware\VMware Player on my Windows 7 machine. –  GrandAdmiral Sep 19 '12 at 18:25
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.