Sign up ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

I installed Ubuntu 12.04.1 LTS on my Mac using Parallels, can you tell me how to display the Launcher inside Ubuntu? I am also having problems with the menubar as it appears to be invisible.

My system information:

MacBook Pro (15-inch Core 2 Duo) - model:Late 2006 – used laptop
RAM: 3GB (Seems 4GB)

10GB for Ubuntu , 512MB RAM FOR UBUNTU

enter image description here

enter image description here


share|improve this question

3 Answers 3

This happened to me just now when installing Ubuntu 14.04 on Parallels Desktop 9 (Build 9.0.24229; Revision 991745; Tuesday, April 1, 2014) for mac (OS 10.9, Macbook Pro) .

The Ubuntu install finished fine as long as I unchecked "Express install" during the new VM setup/install.

After Selecting "Intall Parallels Tools...", my Ubuntu desktop looked identical to the original poster's.

However Ctrl-Alt-T didn't open a Terminal in this state either. I had to do Alt-Ctrl-fn-F1 (Fn to enable the F-keys instead of brightness etc.) to get a terminal, log in, and then follow these instructions on the Parallels Desktop website:

Worked perfectly and got Ubuntu (and unity) working properly again.

The instructions from the Parallels Desktop help site are copied here (copied on 2014-05-25):

  • Start your Ubuntu 14.04 virtual machine and press Ctrl+Alt+F2 to activate the command line
  • Enter your username and the password
  • Locate xorg.conf.XXXXXXXX (where XXXXXXXX is a current date when the xorg.conf file was created) via:
  • ls -l /etc/X11/
  • Check whether this file contains "Parallels" entries, via:
  • pico /etc/X11/xorg.conf.XXXXXXXX
  • (see orig. Parallels website for what the xorg.conf.xxxx file should look like)
  • Ctrl-X to exit pico (or exit whatever editor you used)

Then Type in the commands:

  • sudo mv /etc/X11/xorg.conf.XXXXXXXX /usr/share/X11/xorg.conf.d/xorg.conf
  • export DISPLAY=:0
  • gsettings reset org.compiz.core:/org/compiz/profiles/unity/plugins/core/ active-plugins
  • Press Ctrl+Alt+F7 to exit the command line
  • Reboot your virtual machine.

Actually, because the unity GUI didn't show any obvious way to reboot, I stayed in the command line (ctrl-alt-Fn-F1) and used the command shutdown -r now

share|improve this answer
Thanks for the suggestion. –  Demis May 26 '14 at 4:44

First of all, you can still start terminal using Ctrl+Alt+T.

I followed some of these forum links and one reported issue had to do with a missing "". See

Confirmed that this was the issue by running "unity --reset". This made unit work even worse but showed a proper error message involving

A solution from one of the forum posts worked for me:

sudo ln -s /usr/lib/parallels-tools/tools/prltools.x64/xorg.7.1/usr/lib/ /usr/lib/x86_64-linux-gnu/mesa/
sudo ldconfig
sudo reboot

Apparently the error was caused by an upgrade of Parallels tools failing to install properly. The lack of interest from Parallels in the forums makes me worried about the future of their linux support.

share|improve this answer
I just had the same problem I believe. Parallels tools set up some but not all of the symbolic links when they replaced libGL with their own version. This is Parallels 9, Ubuntu 13.10, and over a year later... –  drfrogsplat Jan 28 '14 at 6:02

agree with Demis, however, my system won't work until I remove parallels tool and installed it back (not just reinstall).

I'm writing my workaround here

go to commandline mode using ctrl-option-fn-f1

enter username and password

on menu, "choose reinstall parallel tools”

type this command

$ cd /media/nugroho/Parallels\ Tools/

$ sudo ./install

on choice whether we want to reinstall or remove, choose remove

after it done reboot using $ sudo init 6

after login, go back to commandline mode

$ cd /media/nugroho/Parallels\ Tools/

$ sudo ./install

this time choose install (it does autmatically anyway, :) )

after done choose reboot


share|improve this answer
Link only answers are usually not wanted. It's better to summarize the content of the link in your answer. So it's easier to see what the link is about and your answer doesn't become worthless in case the link breaks. –  Minos Oct 13 '14 at 10:22

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.