Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am running Ubuntu 10.04 64-bit, and when I attempt to start Nautilus from the command line, it does not appear -- although a PID is generated. As root/sudo i can start Nautilus fine.

One note: I run e16 as the windows manager, so I do not use Nautilus to draw my desktop. However, even under this configuration, Nautilus used to run fine as a "regular" user.

The permissions for Nautilus are the same as the other packages in /usr/bin. I believe this is a Gnome issue, but I'm fumbling at this point.

share|improve this question

1 Answer 1

$ nautilus --no-desktop

should do the trick.

share|improve this answer
    
No, I'm afraid not. Same symptoms: No GUI for Nautilus, but there is a PID. But thank you for responding. –  user7978 Dec 28 '10 at 2:03
    
It may help to add the "--browser" option. You can use the "--no desktop" option with it, but that doesn't seem to make any difference when I use other window managers. I'm not posting this as an answer because I've never used e16 and don't know if it'll work :) Oh, and adding the directory path to the end of your command might help as well. –  Deadite81 Dec 28 '10 at 4:21

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.