Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have installed Nemo (a fork of Nautilus created by the Linux Mint Team) in my Ubuntu 12.04.1 LTS with Gnome Shell 3.4.2. I followed the instructions DefaultFileManager on help.ubuntu.com, changing the "inode" and "x-directory" in the file "defaults.list", to make Nemo my default file manager.

Now everything works perfectly, except for one thing: opening folders from desktop.

I have set the option "Have file manager handle the desktop" on. Cool. The problem is that the desktop seems to be handled by Nautilus only, even if I have set another file manager as default. Every time I double click a folder on the desktop, it is opened by Nautilus, not Nemo.

Does anybody know how to fix this?

share|improve this question
    
The Desktop expects nautilus to handle it not nemo, even though nemo is a fork of nautilus the "easist" thing would be to uninstall nautilus but i'm afraid it would take gnome shell with it. –  Uri Herrera Sep 19 '12 at 17:27
    
Thanks for your answer, Uri Herrera. I understand your point, but if the Desktop expects Nautilus to handle it, it's because there is something somewhere telling it so, right? Where is this information stored? Can't it be changed? :) brunces –  brunces Sep 19 '12 at 18:18
    
Might be because Gnome shell is compiled with nautilus "in mind" and expected to be used with nautilus because of this, that's what i believe. –  Uri Herrera Sep 19 '12 at 18:20
add comment

6 Answers 6

Found a solution here: http://www.fandigital.com/2013/01/set-nemo-default-file-manager-ubuntu.html

The following command once typed into a terminal window (Ctrl+Alt+T) makes nemo default

xdg-mime default nemo.desktop inode/directory application/x-gnome-saved-search
share|improve this answer
add comment

Taken from this page:
Open up Terminal, and run the following commands (one-by-one):

sudo add-apt-repository ppa:gwendal-lebihan-dev/cinnamon-nightly
sudo apt-get update
sudo apt-get install nemo nemo-fileroller

Note the following:

Installing Nemo will also install latest Cinnamon (currently Cinnamon 1.6) into your Ubuntu installation, but it won't replace your default Ubuntu session; it just add a new entry in login session list). Be aware that Nemo is still unstable.

As of now, most GTK themes available are not designed specifically for Nemo, so Nemo won't look good when using those themes.
Also, problems with the desktop may arise: How to completely integrate Nemo with Ubuntu?

BTW: You could have probably found an answers yourself here on AU or by googling.

share|improve this answer
add comment

Nemo 1.7.2 is now available in the official repositories through Ubuntu Software Center, and this installation method doesn't install Cinnamon. I've installed Nemo thusly, and then used the xdg-mime command, with very satisfactory results -- removable media are now automatically opened in Nemo not Nautilus, with Tree View (which is what I wanted).

ADDED: While tinkering with the system when something is not broken is probably not recommended, for the curious, here is additional information on the creation and structure of Unity launchers that are involved in application integration with the Unity desktop.

https://help.ubuntu.com/community/UnityLaunchersAndDesktopFiles

Proceed only with extreme caution.

share|improve this answer
add comment

After installing Nemo from the Cinnamon-PPA + setting it as default file manager with:

xdg-mime default nemo.desktop inode/directory application/x-gnome-saved-search

..you still would like to disable nautilus handling the desktop and instead use nemo.

To disable natuilus, do

gsettings set org.gnome.desktop.background show-desktop-icons false

But then I'm not sure how to make Nemo handle it instead.

share|improve this answer
add comment

Nemo is set to handle the desktop by default but Nautilus overrides that so Add Nemo to the mime defaults and disable Nautilus

xdg-mime default nemo.desktop inode/directory application/x-gnome-saved-search
gsettings set org.gnome.desktop.background show-desktop-icons false
share|improve this answer
add comment

Also if you have nautilus and nemo both running then saves from applications like Libreoffice will take a long time. solution is to make nemo the default file manager and purge nautilus. Unfortunately sometimes upgrades will re-install nautilus and make it the default manager, then you have the same slow save problem until you again purge one or the other. I like nemo as it has by default "open as root". This is very useful as no matter what sort of user you are with Linux you will end up needing to have root privileges for many files.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.