Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I had a spare, old external usb hard disk which stopped working long time back due to improper removal of disk. I tried fixing it in windows (when I did not have ubuntu yet), however I couldn't fix it.

So I tried formatting the disk and creating a new partition using the disk utility in ubuntu. However it seems to keep running without any indication of the progress or whatsoever. I have no idea what is happening. I have attached a screenshot below to show what I mean.

alt text

As you can from the screenshot above it seems to be working on it but no indication on the progress or what it is doing. Any attempt to exit it or do any other task like safe removal or format partition leads to the the following dialog box.

alt text

What should I do? Wait or restart the computer..???

Update: I installed gparted as per the answer however when creating the partition of the type ext4 I had the same problem. It ran for hours (I waited around 10 hours) and when I checked it was stuck. The application froze. So I restarted and then deleted the disk and then created a new partition of the type ntfs and it was done in 5 minutes!!

The problem seems to be creating a ext4 partition. Any reasons why?

share|improve this question
add comment

3 Answers

up vote 1 down vote accepted

Install and use gparted to format the usb-drive. It is safish to simply restart your computer, considering you want to wipe the drive and it was "broken" before. Takes about a minute to format 2GB drive.

share|improve this answer
add comment

try to remove the disk from the USB enclosure and hook it up directly to an internal port (SATA or PATA) then check S.M.A.R.T. maybe there is a problem with the disk or USB controller itself

share|improve this answer
add comment

I know this is an old question but I had the exact same problem. The Disk Utility just carried on for ages without giving me any idea how long it was going to take.

In the end I gave up, attached the USB drive to a PC running Windows Vista and formatted it as Ext3 using Paragon Partition Manager 11, job done in under 2 minutes!

share|improve this answer
    
-1, this does not answer how to correct the problem in Ubuntu. –  Tom Brossman Sep 24 '12 at 7:59
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.