Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'd like to open the GKrellM system monitor so that it is present on all virtual desktops. How to do that?

Using Ubuntu 11.04 (Natty) & classic GNOME (not Unity).

Bonus questions:

  • How to skip the gkrellm window from the taskbar (on the bottom of the screen)?
  • How to launch it automatically when logging in?

(I can ask those separately, too. Or please point out if some of these are already covered.)

share|improve this question

2 Answers 2

up vote 1 down vote accepted

Instead of using a starting option, set the rules in your window manager. I'm not sure whether you use Compiz, if yes, you can set the rules in Compiz using the compiz settings manager (ccsm). Again, since I have only 10.04 and 12.04 around, I can only give you a rough guide.

  1. Open ccsm, enable the plugin "Window rules" (under Window Management). If you don't have ccsm installed yet, you can do that by typing

    sudo apt-get install compizconfig-settings-manager
    

    The usual caveats about the stability of ccsm and problems when meddling with Compiz settings apply.

  2. In the field called "sticky", type

    class=Gkrellm
    
  3. Answer to the second question: copy the same under "Skip taskbar", "Skip pager" etc.

  4. To launch automatically, start gnome-session-properties and click on "Add" button on the right. Add the name (Gkrellm), command (gkrellm) and comment ("Who came up with the ridiculous name >>gkrellm<

EDIT: turns out that gkrellm actually has a "sticky" and "skip taskbar" option. They do not work properly on my 10.04 system (error message: Cannot open config file /home/nexus/.gkrellm2/user-config.new for writing.), but works without any problems on 12.04. In any case, the WM solution is applicable to any such problem.

share|improve this answer
    
Thanks! I installed compizconfig-settings-manager, and after looking around a little, found the place (in ccsm) to make GKrellM sticky etc (screenshot). (I edited your answer a little.) –  Jonik Sep 20 '12 at 7:51

I've been able to rid the taskbar of gkrellm by restarting Cinnamon. Click on Settings (the ^ on the panel ) and then Troubleshoot. Then click Restart Cinnamon. This isn't a persistent fix but it works as long as your session.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.