Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm seeing this unwanted behaviour eversince Unity came to Ubuntu. The Unity's Launcher randomly "steals" the endpoint for the minimizing animations from Docky. In other words, when I click on an icon in Docky to minimize a window, that window minimizes to Unity instead of Docky. That happens most of the time to all of the windows, although sometimes, also randomly, it happens that the windows minimize to Docky, but very rarely.

Here's how it looks when I minimize a window: enter image description here Here's how both animations should look: enter image description here

share|improve this question
    
I'm not sure of the question -- are you reporting a bug or asking for a workaround? –  belacqua Nov 17 '12 at 20:05
1  
I'm asking whether this is considered a bug in the first place. If not, is there anything that can be done to make all the windows minimize to and maximize from the actual used dock (in my case Docky). –  Томица Кораћ Nov 18 '12 at 6:49

4 Answers 4

http://www.hackourlife.com/awn-vs-cairo-dock-vs-docky-mac-style-linux-docks-reviewed/

have you tried one of the alternatives? (ie. awn? / cairo?)

*(i used to use awn and can speak for its ease on the old 10.10 environment, but haven't attempted since the changes went in to x in 11.04< ... but i'm it's still; stable at least.)

while i know this isn't a direct fix to your problems, it may be a good temporary alternative. :D

share|improve this answer
1  
thanks @knope for your suggestion. Yes, I've tried many docks. I've been using AWN for years and still think it's probably the best one. I don't quite like Cairo just because it's got way too many nuts and bolts to tweak before you set it right for yourself. However, I switched to Docky because it's so light-weight, and yet it has almost everything I need from a dock. Also, I don't think any other dock has its fish-eye zooming effect. Many have something similar, but it's just not the same thing. –  Томица Кораћ Oct 7 '12 at 17:57

Checking the animation settings in compizConfig might help.

share|improve this answer
    
Can you provide more information about how to do this? –  Eliah Kagan Oct 12 '12 at 5:59
    
Well i checked there is not a specific setting for changing where the window minimizes to. The fish-eye zooming effect or magic lamp, is actually a window animation that compiz handles. You could try other docks and see if they have same behavior, and if you don't already have it i would suggest installing compizConfig sudo apt-get install compizconfig-settings-manager and in the animations settings page you can change the minimize animation. Compiz is an advanced tool so use with care. (-: –  Aaron Oct 12 '12 at 15:44
1  
So, does this address the problem that Томица Кораћ has asked about? That's what I'm wondering--will changing settings pertaining to these Compiz animations fix that issue? –  Eliah Kagan Oct 12 '12 at 16:05
    
@Aaron thanks for your input. Unfortunately, I'm not able to fix this through CCSM. In CCSM > Effects > Effect Settings > Magic Lamp, there is a setting called 'Open/Close Moving End'. I tried both enabling and disabling this, but with no visible change, even after rebooting. I've tried AWN and Plank and they don't seem to have this problem. –  Томица Кораћ Oct 13 '12 at 10:14
1  
I think I've discovered another weird detail: windows whose icons are locked to Unity's Launcher always or almost always (not sure) minimize to Docky, as they should. But windows whose icons are not locked to Unity's Launcher, that is windows whose icons show in Unity's Launcher only when they're open, always or almost always land to Unity's Launcher. Wicked... –  Томица Кораћ Oct 16 '12 at 21:10

I am having the same or a related problem trying to minimize windows only to docky. I think I've found a solution. If you go to docky's settings and set the configuration to none then the window minimizing will only go to your dock. I am still playing with it to see if it will continue do this.

share|improve this answer
1  
Set what configuration to 'None'? –  Томица Кораћ Nov 18 '12 at 6:56
    
@91448 The dock hiding config. @ user108829 You don't have to set it to that, you just have to change that option to something else. –  user171354 Feb 20 at 16:54
    
were is that dock hiding config? –  Vasil Valchev May 13 at 8:17

Well, the best thing you can do is to disable the Unity plugin using CCSM. This will remove the Unity launcher, but the upper panel would disappear too. Then, install gnome-panel:

sudo apt-get install gnome-panel

And add it to start-up applications. Log out andd then log back in.

That should solve your problem.

share|improve this answer
1  
SalsaRui thanks, but I don't want to disable the entire Unity. I like the way Unity develops, for now the only unreasonable thing about Unity is the terrible Launcher. –  Томица Кораћ Sep 18 '13 at 8:42

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.